<!DOCTYPE html><html lang="en-US" class="no-js no-svg"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="profile" href="http://gmpg.org/xfn/11"><link rel='dns-prefetch' href='//cdnjs.cloudflare.com' /><link rel='dns-prefetch' href='//content.jwplatform.com' /><link rel='dns-prefetch' href='//cookie-cdn.cookiepro.com' /><link rel='dns-prefetch' href='//www.googletagservices.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//use.fontawesome.com' /><link rel='dns-prefetch' href='//cdn.tsln.com' /><style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important}</style><link rel='stylesheet' id='tribe-tooltip-css'  href='https://cdn.tsln.com/wp-content/cache/busting/13/wp-content/plugins/the-events-calendar/common/src/resources/css/tooltip.min-4.9.11.2.css' type='text/css' media='all' /><link rel='stylesheet' id='wp-block-library-css'  href='https://cdn.tsln.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' /><link rel='stylesheet' id='wp-polls-css'  href='https://cdn.tsln.com/wp-content/cache/busting/13/wp-content/plugins/wp-polls/polls-css-2.75.2.css' type='text/css' media='all' /><style id='wp-polls-inline-css' type='text/css'>.wp-polls .pollbar{margin:1px;font-size:6px;line-height:8px;height:8px;background-image:url(https://cdn.tsln.com/wp-content/plugins/wp-polls/images/default/pollbg.gif);border:1px solid #c8c8c8}</style><link rel='stylesheet' id='wpsl-styles-css'  href='https://cdn.tsln.com/wp-content/cache/busting/13/wp-content/plugins/wp-store-locator/css/styles.min-2.2.23.css' type='text/css' media='all' /><link rel='stylesheet' id='swift-main-css-css'  href='https://cdn.tsln.com/wp-content/cache/busting/13/wp-content/themes/swift-news-theme/assets/css/main.min-1564424405.css' type='text/css' media='all' /><link rel='stylesheet' id='google-fonts-css-css'  href='https://fonts.googleapis.com/css?family=Heebo%3A400%2C700%7CLora%3A400%2C400i%2C700&#038;ver=1.0' type='text/css' media='all' /><link rel='stylesheet' id='fontawesome-css-css'  href='https://use.fontawesome.com/releases/v5.4.1/css/all.css?ver=5.0.13' type='text/css' media='all' /><link rel='stylesheet' id='weather-icons-css-css'  href='https://cdn.tsln.com/wp-content/cache/busting/13/wp-content/themes/swift-news-theme/assets/css/vendors/weather-icons/weather-icons.min-2.0.css' type='text/css' media='all' /><link rel='stylesheet' id='bootstrap-calendar-css-css'  href='https://cdn.tsln.com/wp-content/cache/busting/13/wp-content/themes/swift-news-theme/assets/css/vendors/bootstrap-datepicker/bootstrap-datepicker-1.8.0.css' type='text/css' media='all' /><link rel='stylesheet' id='fancybox-css-css'  href='https://cdnjs.cloudflare.com/ajax/libs/fancybox/3.5.6/jquery.fancybox.min.css?ver=3.5.6' type='text/css' media='all' /><link rel='stylesheet' id='lightslider-css-css'  href='https://cdn.tsln.com/wp-content/cache/busting/13/wp-content/themes/swift-news-theme/assets/css/vendors/lightslider-1.1.6.css' type='text/css' media='all' /><link rel='stylesheet' id='lightgallery-css-css'  href='https://cdn.tsln.com/wp-content/cache/busting/13/wp-content/themes/swift-news-theme/assets/css/vendors/lightgallery-1.6.11.css' type='text/css' media='all' /> <script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/jquery/3.3.1/jquery.min.js?ver=3.3.1'></script> <script type='text/javascript' src='https://content.jwplatform.com/libraries/ouzag7i3.js?ver=1.0.0'></script> <script type='text/javascript' src='https://www.googletagservices.com/tag/js/gpt.js?ver=1.0.0'></script> <script type='text/javascript'>var dfp = dfp || {}; dfp.cmd = dfp.cmd || [];</script> <script data-minify="1" type='text/javascript' src='https://cdn.tsln.com/wp-content/cache/min/13/wp-content/themes/swift-news-theme/assets/js/vendors/dfp-f055ce822897ed54f1e742a5fd803463.js'></script> <script type='text/javascript'>var opts = {
	    "tag": {
	        networkId: 5195,
	        adUnit: "FPC_TSLN/ROS/news"
	    },
			"services": {
		    "async": true,
		    "singleRequest": false,
		    "collapseEmpty": true,
		    "disableInitialLoad": false,
		    //"ppid": "12hjDojdj2JHK32228FHKJBskMOI2ndnjndn",
		    "requestNonPersonalizedAds": false
			},
			// Browser size breakpoints.
			"breakpoints": [{
				 "name": "xs",
			    "begin": 0,
			    "end": 319
			}, {
					"name": "s",
			    "begin": 320,
			    "end": 767
			}, {
				"name": "m",
			    "begin": 768,
			    "end": 1023
			}, {
				"name": "l",
			    "begin": 1024,
			    "end": 1439
			}, {
				"name": "xl",
			    "begin": 1440,
			    "end": Infinity
			}]
			//"callbacks": {...}
		},
		targeting = {
			"UrlHost" : "www.tsln.com",
			"UrlPath" : "/news/results-national-high-school-rodeo-association-finals-81",
			
		},
		slots = [{
      "domId": "ad-half-page",
      "sizes": {
        "xs": [],
        "s": [],
        "m": [],
        "l": [[300, 600]],
        "xl": [[300, 600]]
      },
      "targeting": {
          "position": "3"
      }
},{
      "domId": "ad-parallax",
      "sizes": {
        "xs": [[300,300]],
        "s": [[300,300]],
        "m": [[600,300]],
        "l": [[600,300]],
        "xl": [[600,300]]
      },
      "targeting": {
          "position": "1"
      }
},{
      "domId": "ad-parallax2",
      "sizes": {
        "xs": [[300,600]],
        "s": [[300,600]],
        "m": [[300,600]],
        "l": [[600,300]],
        "xl": [[600,300]]
      },
      "targeting": {
          "position": "2"
      }
},{"domId":"ad-marquee","sizes":{"xs":[[320,50]],"s":[[320,50]],"m":[[970,250]],"l":[[970,250]],"xl":[[970,250]]},"targeting":{"position":"1"}},{"domId":"ad-small-top","sizes":{"xs":[[320,50]],"s":[[320,50]],"m":[[320,50]],"l":[[320,50]],"xl":[[320,50]]},"targeting":{"position":"1"}},{"domId":"ad-big-box4","sizes":{"xs":[[300,250]],"s":[[300,250]],"m":[[300,250]],"l":[[300,250]],"xl":[[300,250]]},"targeting":{"position":"4"}},{
      "domId": "ad-big-box3",
      "sizes": {
        "xs": [[300, 250]],
	"s": [[300, 250]],
	"m": [[300, 250]],
	"l": [[300, 250]],
	"xl": [[300, 250]]
      },
      "targeting": {
          "position": "3"
      }
},{
      "domId": "ad-big-box2",
      "sizes": {
        "xs": [[300, 250]],
	"s": [[300, 250]],
	"m": [[300, 250]],
	"l": [[300, 250]],
	"xl": [[300, 250]]
      },
      "targeting": {
          "position": "2"
      }
},{
      "domId": "ad-big-box1",
      "sizes": {
        "xs": [[300, 250]],
	"s": [[300, 250]],
	"m": [[300, 250]],
	"l": [[300, 250]],
	"xl": [[300, 250]]
      },
      "targeting": {
          "position": "1"
      }
},{
      "domId": "ad-top",
      "sizes": {
        "xs": [[320, 50]],
        "s": [[320, 50]],
        "m": [[728, 90]],
        "l": [[728, 90]],
        "xl": [[728, 90]]
      },
      "targeting": {
          "position": "1"
      }
},{
      "domId": "ad-bottom",
      "sizes": {
        "xs": [[320, 50]],
        "s": [[320, 50]],
        "m": [[728, 90]],
        "l": [[728, 90]],
        "xl": [[728, 90]]
      },
      "targeting": {
          "position": "2"
      }
},];

		dfp.cmd.push(function() {
		    dfp.init(opts, targeting, slots);
		});</script> <link rel='https://api.w.org/' href='https://www.tsln.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.tsln.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.tsln.com/wp-includes/wlwmanifest.xml" /><link rel='prev' title='Results from 123rd Cheyenne Frontier Days' href='https://www.tsln.com/news/results-from-123rd-cheyenne-frontier-days/' /><meta name="generator" content="WordPress 5.2.2" /><link rel="canonical" href="https://www.tsln.com/news/results-national-high-school-rodeo-association-finals-81/" /><link rel='shortlink' href='https://www.tsln.com/?p=104227' /><link rel="alternate" type="application/json+oembed" href="https://www.tsln.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.tsln.com%2Fnews%2Fresults-national-high-school-rodeo-association-finals-81%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.tsln.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.tsln.com%2Fnews%2Fresults-national-high-school-rodeo-association-finals-81%2F&#038;format=xml" /> <script>window.SGPMPopupLoader=window.SGPMPopupLoader||{ids:[],popups:{},call:function(w,d,s,l,id){
									w['sgp']=w['sgp']||function(){(w['sgp'].q=w['sgp'].q||[]).push(arguments[0]);};
									var sg1=d.createElement(s),sg0=d.getElementsByTagName(s)[0];
									if(SGPMPopupLoader && SGPMPopupLoader.ids && SGPMPopupLoader.ids.length > 0){SGPMPopupLoader.ids.push(id); return;}
									SGPMPopupLoader.ids.push(id);
									sg1.onload = function(){SGPMPopup.openSGPMPopup();}; sg1.async=true; sg1.src=l;
									sg0.parentNode.insertBefore(sg1,sg0);
									return {};
								}};</script><script>SGPMPopupLoader.call(window,document,'script','https://popupmaker.com/assets/lib/SGPMPopup.min.js','0283fc31');</script><meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://www.tsln.com"><link rel="https://theeventscalendar.com/" href="https://www.tsln.com/wp-json/tribe/events/v1/" /><script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
          (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
          m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
        })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
        ga('create', 'UA-4028663-26', 'auto');
        ga('create', 'UA-4028663-63', 'auto', {'name': 'newTracker'});
 	      ga('require', 'displayfeatures');
	      ga('require', 'linkid');</script> <script>(function() {
			  var _fbq = window._fbq || (window._fbq = []);
			  if (!_fbq.loaded) {
			    var fbds = document.createElement('script');
			    fbds.async = true;
			    fbds.src = '//connect.facebook.net/en_US/fbds.js';
			    var s = document.getElementsByTagName('script')[0];
			    s.parentNode.insertBefore(fbds, s);
			    _fbq.loaded = true;
			  }
			  _fbq.push(['addPixelId', '356889104458573']);
			  
			  })();
			  window._fbq = window._fbq || [];
			  window._fbq.push(["track", "PixelInitialized", {}]);</script><noscript> <img height="1" width="1" border="0" alt="" style="display:none" src="https://www.facebook.com/tr?id=356889104458573&ev=PixelInitialized" /> </noscript> <script>var _qevents = _qevents || [];
					(function() {
						var elem = document.createElement('script');
						elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
						elem.async = true;
						elem.type = "text/javascript";
						var scpt = document.getElementsByTagName('script')[0];
						scpt.parentNode.insertBefore(elem, scpt);
					})();</script><meta name="google-site-verification" content="VcnGTKvJc85D8wBtQOQroo2cxIHzauDOYXANOeL989Y" /><meta name="__sync_contentCategory" content="Paid" /><meta name="__sync_tenantId" content="swc_gt"><link rel="shortcut icon" href="https://cdn.tsln.com/wp-content/uploads/sites/13/2019/04/favicon.ico"><link rel="apple-touch-icon" sizes="180x180" href="https://cdn.tsln.com/wp-content/uploads/sites/13/2019/04/apple-touch-icon.png"><link rel="icon" type="image/png" sizes="32x32" href="https://cdn.tsln.com/wp-content/uploads/sites/13/2019/04/favicon-32x32.png"><title>Results: National High School Rodeo Association Finals | TSLN.com</title><meta name="description" content="Top 15 from each event. For more results, see nhsra.com Barrel Racing Average 1. (UT) Macee McAllister, St. George, Utah, 51.937 2. (MT) Shai McDonald, Gardiner, Mont., 52.276 3. (SK) Brooke Lang, Cadillac, Saskatchewan, Can.,..." /><meta property="og:title" content="Results: National High School Rodeo Association Finals"/><meta property="og:description" content="Top 15 from each event. For more results, see nhsra.com Barrel Racing Average 1. (UT) Macee McAllister, St. George, Utah, 51.937 2. (MT) Shai McDonald, Gardiner, Mont., 52.276 3. (SK) Brooke Lang, Cadillac, Saskatchewan, Can.,..."/><meta property="og:url" content="https://www.tsln.com/news/results-national-high-school-rodeo-association-finals-81/"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:site" content="@TSLivestockNews"/><meta property="og:image" content="https://www.tsln.com/wp-content/uploads/sites/13/2019/04/facebook-thumbnail-1200.jpg"/><meta property="og:image:type" content="image/jpeg"/><meta property="og:image:width" content="1200" /><meta property="og:image:height" content="630" /><meta name="sniply-options" content="block" /><meta property="article:publisher" content="ttps://www.facebook.com/tslivestocknews/" /><meta name="author" content="" /><meta property="og:type" content="article" /> <script type="application/ld+json">{
				  "@context": "https://schema.org",
				  "@type": "NewsArticle",
				  "mainEntityOfPage": {
				    "@type": "WebPage",
				    "@id": "https://google.com/article"
				  },
					
				  "headline": "Results: National High School Rodeo Association Finals",
				  "image": [
				    "https://www.tsln.com/wp-content/uploads/sites/13/2019/04/facebook-thumbnail-1200.jpg"
				   ],
				  "datePublished": "2019-07-29 16:26:00",
				  "dateModified": "2019-07-29 16:26:00",
					"author": {
						"@type": "Person",
						"name": "Staff"
					},
				   "publisher": {
				    "@type": "Organization",
				    "name": "TSLN.com",
				    "logo": {
				      "@type": "ImageObject",
				      "url": "https://www.tsln.com/wp-content/uploads/sites/13/2019/04/tsln-logo-2x.png"
				    }
				  },
				  "description": "Top 15 from each event. For more results, see nhsra.com Barrel Racing Average1. (UT) Macee McAllister, St. George, Utah, 51.9372. (MT) Shai McDonald, Gardiner, Mont., 52.2763. (SK) Brooke Lang, Cadillac, Saskatchewan, Can., 52.3044. (CO) Kinlie Brennise, Craig, Colo., 52.3155. (UT) Amanda Butler, Payson, Utah, 52.3236. (ID) Lindsey Peterson, Ogden, Utah, 52.4767. (OK) Jaiden Wilmoth, Gentry,&hellip;"
				}</script><meta property="fb:app_id" content="498110130268044" /><meta name="pubdate" content="20190729"></head><body class="post-template-default single single-post postid-104227 single-format-standard tribe-no-js tsln category-news"><div id="fb-root"></div> <script>(function(d, s, id) {
			  var js, fjs = d.getElementsByTagName(s)[0];
			  if (d.getElementById(id)) return;
			  js = d.createElement(s); js.id = id;
			  js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v3.2&appId=498110130268044&autoLogAppEvents=1';
			  fjs.parentNode.insertBefore(js, fjs);
			}(document, 'script', 'facebook-jssdk'));</script> <script>function get_cookie_value(a) {
					var b = document.cookie.match('(^|;)\\s*' + a + '\\s*=\\s*([^;]+)');
					return b ? b.pop() : '';
				}
				var free_site = true;
var show_survey = false;
				var syncwall_cookie = get_cookie_value('syncwall-active-subscriber');

				if ( syncwall_cookie !== null ) {
					//console.log('SwiftDebug | js free_site: ' + free_site );
					//console.log('SwiftDebug | js show_survey: ' + show_survey );
					//console.log('SwiftDebug | js syncwall-active-subscriber cookie value: ' + syncwall_cookie );
				}</script> <script>if ( (free_site === true && show_survey === true) || (free_site === false && ( show_survey === true && (syncwall_cookie !== null && syncwall_cookie !== "true") ) ) ) {

	        console.log("SwiftDebug | Google Survey enabled");

					(function() {
	          var ARTICLE_URL = window.location.href;
	          var CONTENT_ID = 'everything';
	          document.write(
	            '<scr'+'ipt '+
	            'src="//survey.g.doubleclick.net/survey?site=_'+
	            '&amp;url='+encodeURIComponent(ARTICLE_URL)+
	            (CONTENT_ID ? '&amp;cid='+encodeURIComponent(CONTENT_ID) : '')+
	            '&amp;random='+(new Date).getTime()+
	            '" type="text/javascript">'+'\x3C/scr'+'ipt>');
	        })();

	      }
	      else {
	        console.log("SwiftDebug | Google Survey disabled");
	      }</script> <header><nav id="nav-publication" class="navbar navbar-expand d-none d-lg-flex"><div class="d-flex mr-auto"> <a class="logo navbar-brand" href="https://www.tsln.com"> <img  src="https://cdn.tsln.com/wp-content/uploads/sites/13/2019/04/tsln-logo.png" srcset="https://www.tsln.com/wp-content/uploads/sites/13/2019/04/tsln-logo-2x.png 2x" alt="TSLN.com Logo"> </a><div class="align-self-end"> <span class="tag-line navbar-text">What Ranchers Read</span></div></div><div class="d-flex"><form class="search-form form-inline" action="https://www.tsln.com/search-results/"> <input class="search-input form-control" type="search" placeholder="Search" aria-label="Search" name="q"> <button class="search-button" type="submit"><i class="fas fa-search"></i></button> <input type="hidden" name="sort" value="relevance" /> <input type="hidden" name="range" value="2019-04-30" /></form><ul class="nav-menu navbar-nav"><li class="nav-item"> <a class="nav-link" href="/forecast/"> <i class="wi wi-night-alt-partly-cloudy"></i> 67&deg; </a></li><li class="nav-item nav-account"> <a class="nav-link" href="https://swiftiservices.dticloud.com/cmo_cmo/subscriber/web/signin.html?siteId=TSLN">My Account</a> | <span id="logged-out"><a class="nav-link" id="loginBtn" href="javascript:void(0);">Login</a></span> <span id="logged-in" style="display: none;"><a class="nav-link" id="logoutBtn" href="javascript:void(0);">Logout</a></span></li></ul></div></nav><nav id="nav-main" class="navbar navbar-expand d-none d-lg-flex"><div class="d-flex mr-auto"><div id="nav-main-menu"><ul class="nav-menu navbar-nav"><li class="nav-item menu-item-has-children dropdown"> <a class="nav-link dropdown-object" id="menu-item-dropdown-5" href="https://www.tsln.com/">News</a><ul class="dropdown-menu shadow-sm" aria-labelledby="menu-item-dropdown-5" role="menu"><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.tsln.com/cattle-health/">Cattle Health</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.tsln.com/news/ag-political-issues/">Ag Political Issues</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.tsln.com/news/ranching-legacies/">Ranching Legacies</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.tsln.com/news/ranch-management/">Ranch Management</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.tsln.com/news/research-tech/">Research &#038; Tech</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.tsln.com/news/people-of-ag/">People of Ag</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.tsln.com/obituaries/">Obituaries</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.tsln.com/news/calendar/">Ag Events Calendar</a></li></ul><li class="nav-item menu-item-has-children dropdown"> <a class="nav-link dropdown-object" id="menu-item-dropdown-272" href="https://www.tsln.com/horse-rodeo/">Horse &#038; Rodeo</a><ul class="dropdown-menu shadow-sm" aria-labelledby="menu-item-dropdown-272" role="menu"><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.tsln.com/horse-rodeo/">News/Features</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.tsln.com/horse-rodeo/horse-health/">Horse Health</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.tsln.com/rodeo-standings/">Rodeo Standings</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://cavvysavvy.tsln.com/">Cavvy Savvy</a></li></ul><li class="nav-item menu-item-has-children dropdown"> <a class="nav-link dropdown-object" id="menu-item-dropdown-275" href="https://www.tsln.com/opinion/">Opinions/Columns</a><ul class="dropdown-menu shadow-sm" aria-labelledby="menu-item-dropdown-275" role="menu"><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.tsln.com/opinion/guest-opinions/">Guest Opinions</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.tsln.com/opinion/cartoons/">Cartoons</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.tsln.com/opinion/baxter-black/">Baxter Black</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.tsln.com/opinion/day-writing/">Day Writing</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.tsln.com/opinion/lee-pitts/">Lee Pitts</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.tsln.com/opinion/outside-circle/">Outside Circle</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.tsln.com/opinion/pastor-in-the-pasture/">Pastor in the Pasture</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.tsln.com/opinion/varileks-cattle-call/">Varilk's Cattle Call</a></li></ul><li class="nav-item menu-item-has-children dropdown"> <a class="nav-link dropdown-object" id="menu-item-dropdown-30187" href="https://www.tsln.com/market-reports/">Markets</a><ul class="dropdown-menu shadow-sm" aria-labelledby="menu-item-dropdown-30187" role="menu"><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.tsln.com/market-reports/market-results/">Livestock Market Reports</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.tsln.com/market-reports/sale-reports/">Sale Reports</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.tsln.com/events/category/sale/list/">Sale Calendar</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.tsln.com/news/farmer-rancher-exchange/">Farmer & Rancher Exchange</a></li></ul><li class="nav-item "> <a class="nav-link " href="https://www.tsln.com/market-reports/sale-reports/">Sale Reports</a></li><li class="nav-item menu-item-has-children dropdown"> <a class="nav-link dropdown-object" id="menu-item-dropdown-278" href="https://www.tsln.com/news/special-interest/">Magazines</a><ul class="dropdown-menu shadow-sm" aria-labelledby="menu-item-dropdown-278" role="menu"><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.tsln.com/news/special-interest/ag-pride/">Ag Pride</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.tsln.com/the-cattle-journal/">The Cattle Journal</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.tsln.com/news/special-interest/forage/">Forage</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.tsln.com/news/special-interest/homeland/">Homeland</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.tsln.com/news/special-interest/horse-roundup/">Horse Roundup</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.tsln.com/news/special-interest/open-season/">Open Season</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.tsln.com/news/special-interest/stallion-showcase/">Stallion Showcase</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.tsln.com/news/special-interest/event-programs/">Event Programs</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.tsln.com/news/special-interest/sale-catalogs/">Sale Catalogs</a></li></ul><li class="nav-item menu-item-has-children dropdown"> <a class="nav-link dropdown-object" id="menu-item-dropdown-101994" href="http://classifieds.tsln.com/">Classifieds</a><ul class="dropdown-menu shadow-sm" aria-labelledby="menu-item-dropdown-101994" role="menu"><li class="nav-item "> <a class="nav-link dropdown-item " href="http://classifieds.tsln.com/category/Employment">Employment</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="http://classifieds.tsln.com/category/Real-Estate-For-Sale">Real Estate</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="http://classifieds.tsln.com/category/Farm-Ranch-Equipment">Farm & Ranch</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://secure.adpay.com/AdEntry.aspx?p=9182">Place an Ad</a></li></ul><li class="nav-item menu-item-has-children dropdown"> <a class="nav-link dropdown-object" id="menu-item-dropdown-102008" href="#">More</a><ul class="dropdown-menu shadow-sm" aria-labelledby="menu-item-dropdown-102008" role="menu"><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.tsln.com/events/">Ag Events Calendar</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://cavvysavvy.tsln.com/">Cavvy Savvy</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.tsln.com/news/farmer-rancher-exchange/">Farmer & Rancher Exchange</a></li></ul></li></ul></div></div><div class="d-flex"> <button class="subscribe-button btn" type="button"><a href="https://www.tsln.com/subscribe/">Subscribe</a></button></div></nav><nav id="nav-mobile" class="d-lg-none d-xl-none py-1 shadow-sm"><div class="d-flex justify-content-between align-items-center"><div class="m-3"> <button class="hamburger-button collapsed" type="button" data-toggle="collapse" data-target="#nav-mobile-menu" aria-controls="nav-mobile-menu" aria-expanded="false" aria-label="Toggle navigation"> <i class="fas fa-bars mr-1"></i> <i class="fas fa-times mr-1"></i> </button></div><div class="logo"> <a class="navbar-brand" href="https://www.tsln.com"> <img  src="https://cdn.tsln.com/wp-content/uploads/sites/13/2019/04/tsln-logo.png" srcset="https://www.tsln.com/wp-content/uploads/sites/13/2019/04/tsln-logo-2x.png 2x" alt="TSLN.com Logo"> </a></div><div class="m-3"> <button class="user-button collapsed" type="button" data-toggle="collapse" data-target="#nav-mobile-account" aria-controls="nav-mobile-account" aria-expanded="false" aria-label="Toggle account"> <i class="fas fa-user mr-1"></i> <i class="fas fa-times mr-1"></i> </button> <button class="search-button collapsed" type="button" data-toggle="collapse" data-target="#nav-mobile-search" aria-controls="nav-mobile-search" aria-expanded="false" aria-label="Toggle search"> <i class="fas fa-search ml-1"></i> <i class="fas fa-times mr-1"></i> </button></div></div></nav><nav id="nav-mobile-menu" class="hamburger-button-dropdown collapse position-absolute shadow-sm d-lg-none d-xl-none"><ul class="nav-menu navbar-nav"><li class="nav-item"> <a class="nav-link" href="#" type="button" data-toggle="collapse" data-target="#sub-menu-5" aria-expanded="false"> <span>News</span> <i class="fas fa-caret-right icon-caret"></i> </a><div id="sub-menu-5" class="collapse sub-menu"><ul class="nav-menu navbar-nav"><li class="section"><a class="nav-link" href="https://www.tsln.com/">View Section ></a></li><li><a class="nav-link infant" href="https://www.tsln.com/cattle-health/" >Cattle Health </a></li><li><a class="nav-link infant" href="https://www.tsln.com/news/ag-political-issues/" >Ag Political Issues </a></li><li><a class="nav-link infant" href="https://www.tsln.com/news/ranching-legacies/" >Ranching Legacies </a></li><li><a class="nav-link infant" href="https://www.tsln.com/news/ranch-management/" >Ranch Management </a></li><li><a class="nav-link infant" href="https://www.tsln.com/news/research-tech/" >Research &#038; Tech </a></li><li><a class="nav-link infant" href="https://www.tsln.com/news/people-of-ag/" >People of Ag </a></li><li><a class="nav-link infant" href="https://www.tsln.com/obituaries/" >Obituaries </a></li><li><a class="nav-link infant" href="https://www.tsln.com/news/calendar/" >Ag Events Calendar </a></li></ul></div></li><li class="nav-item"> <a class="nav-link" href="#" type="button" data-toggle="collapse" data-target="#sub-menu-272" aria-expanded="false"> <span>Horse &#038; Rodeo</span> <i class="fas fa-caret-right icon-caret"></i> </a><div id="sub-menu-272" class="collapse sub-menu"><ul class="nav-menu navbar-nav"><li class="section"><a class="nav-link" href="https://www.tsln.com/horse-rodeo/">View Section ></a></li><li><a class="nav-link infant" href="https://www.tsln.com/horse-rodeo/" >News/Features </a></li><li><a class="nav-link infant" href="https://www.tsln.com/horse-rodeo/horse-health/" >Horse Health </a></li><li><a class="nav-link infant" href="https://www.tsln.com/rodeo-standings/" >Rodeo Standings </a></li><li><a class="nav-link infant" href="https://cavvysavvy.tsln.com/" >Cavvy Savvy </a></li></ul></div></li><li class="nav-item"> <a class="nav-link" href="#" type="button" data-toggle="collapse" data-target="#sub-menu-275" aria-expanded="false"> <span>Opinions/Columns</span> <i class="fas fa-caret-right icon-caret"></i> </a><div id="sub-menu-275" class="collapse sub-menu"><ul class="nav-menu navbar-nav"><li class="section"><a class="nav-link" href="https://www.tsln.com/opinion/">View Section ></a></li><li><a class="nav-link infant" href="https://www.tsln.com/opinion/guest-opinions/" >Guest Opinions </a></li><li><a class="nav-link infant" href="https://www.tsln.com/opinion/cartoons/" >Cartoons </a></li><li><a class="nav-link infant" href="https://www.tsln.com/opinion/baxter-black/" >Baxter Black </a></li><li><a class="nav-link infant" href="https://www.tsln.com/opinion/day-writing/" >Day Writing </a></li><li><a class="nav-link infant" href="https://www.tsln.com/opinion/lee-pitts/" >Lee Pitts </a></li><li><a class="nav-link infant" href="https://www.tsln.com/opinion/outside-circle/" >Outside Circle </a></li><li><a class="nav-link infant" href="https://www.tsln.com/opinion/pastor-in-the-pasture/" >Pastor in the Pasture </a></li><li><a class="nav-link infant" href="https://www.tsln.com/opinion/varileks-cattle-call/" >Varilk's Cattle Call </a></li></ul></div></li><li class="nav-item"> <a class="nav-link" href="#" type="button" data-toggle="collapse" data-target="#sub-menu-30187" aria-expanded="false"> <span>Markets</span> <i class="fas fa-caret-right icon-caret"></i> </a><div id="sub-menu-30187" class="collapse sub-menu"><ul class="nav-menu navbar-nav"><li class="section"><a class="nav-link" href="https://www.tsln.com/market-reports/">View Section ></a></li><li><a class="nav-link infant" href="https://www.tsln.com/market-reports/market-results/" >Livestock Market Reports </a></li><li><a class="nav-link infant" href="https://www.tsln.com/market-reports/sale-reports/" >Sale Reports </a></li><li><a class="nav-link infant" href="https://www.tsln.com/events/category/sale/list/" >Sale Calendar </a></li><li><a class="nav-link infant" href="https://www.tsln.com/news/farmer-rancher-exchange/" >Farmer & Rancher Exchange </a></li></ul></div></li><li class="nav-item"> <a class="nav-link" href="https://www.tsln.com/market-reports/sale-reports/" > <span>Sale Reports</span> </a></li><li class="nav-item"> <a class="nav-link" href="#" type="button" data-toggle="collapse" data-target="#sub-menu-278" aria-expanded="false"> <span>Magazines</span> <i class="fas fa-caret-right icon-caret"></i> </a><div id="sub-menu-278" class="collapse sub-menu"><ul class="nav-menu navbar-nav"><li class="section"><a class="nav-link" href="https://www.tsln.com/news/special-interest/">View Section ></a></li><li><a class="nav-link infant" href="https://www.tsln.com/news/special-interest/ag-pride/" >Ag Pride </a></li><li><a class="nav-link infant" href="https://www.tsln.com/the-cattle-journal/" >The Cattle Journal </a></li><li><a class="nav-link infant" href="https://www.tsln.com/news/special-interest/forage/" >Forage </a></li><li><a class="nav-link infant" href="https://www.tsln.com/news/special-interest/homeland/" >Homeland </a></li><li><a class="nav-link infant" href="https://www.tsln.com/news/special-interest/horse-roundup/" >Horse Roundup </a></li><li><a class="nav-link infant" href="https://www.tsln.com/news/special-interest/open-season/" >Open Season </a></li><li><a class="nav-link infant" href="https://www.tsln.com/news/special-interest/stallion-showcase/" >Stallion Showcase </a></li><li><a class="nav-link infant" href="https://www.tsln.com/news/special-interest/event-programs/" >Event Programs </a></li><li><a class="nav-link infant" href="https://www.tsln.com/news/special-interest/sale-catalogs/" >Sale Catalogs </a></li></ul></div></li><li class="nav-item"> <a class="nav-link" href="#" type="button" data-toggle="collapse" data-target="#sub-menu-101994" aria-expanded="false"> <span>Classifieds</span> <i class="fas fa-caret-right icon-caret"></i> </a><div id="sub-menu-101994" class="collapse sub-menu"><ul class="nav-menu navbar-nav"><li class="section"><a class="nav-link" href="http://classifieds.tsln.com/">View Section ></a></li><li><a class="nav-link infant" href="http://classifieds.tsln.com/category/Employment" >Employment </a></li><li><a class="nav-link infant" href="http://classifieds.tsln.com/category/Real-Estate-For-Sale" >Real Estate </a></li><li><a class="nav-link infant" href="http://classifieds.tsln.com/category/Farm-Ranch-Equipment" >Farm & Ranch </a></li><li><a class="nav-link infant" href="https://secure.adpay.com/AdEntry.aspx?p=9182" >Place an Ad </a></li></ul></div></li><li class="nav-item"> <a class="nav-link" href="#" type="button" data-toggle="collapse" data-target="#sub-menu-102008" aria-expanded="false"> <span>More</span> <i class="fas fa-caret-right icon-caret"></i> </a><div id="sub-menu-102008" class="collapse sub-menu"><ul class="nav-menu navbar-nav"><li class="section"><a class="nav-link" href="#">View Section ></a></li><li><a class="nav-link infant" href="https://www.tsln.com/events/" >Ag Events Calendar </a></li><li><a class="nav-link infant" href="https://cavvysavvy.tsln.com/" >Cavvy Savvy </a></li><li><a class="nav-link infant" href="https://www.tsln.com/news/farmer-rancher-exchange/" >Farmer & Rancher Exchange </a></li></ul></div></li><li class="nav-item"><a class="nav-link" href="https://www.tsln.com/subscribe/"><span>Subscribe</span></a></li></ul></nav><div id="nav-mobile-account" class="user-button-dropdown collapse position-absolute d-lg-none d-xl-none shadow-sm"><div class="row"><div class="col"><a href="https://swiftiservices.dticloud.com/cmo_cmo/subscriber/web/signin.html?siteId=TSLN">My Account</a></div><div class="col"> <span id="logged-out2"><a id="loginBtn2" href="javascript:void(0);">Login</a></span> <span id="logged-in2" style="display: none;"><a id="logoutBtn2" href="javascript:void(0);">Logout</a></span></div></div></div><div id="nav-mobile-search" class="search-button-dropdown collapse position-absolute shadow-sm d-lg-none d-xl-none"><form class="search-form form-inline d-flex" action="https://www.tsln.com/search-results/"> <input class="search-input form-control flex-fill" type="search" aria-label="Search" name="q" placeholder="enter search terms"> <button class="search-button btn" type="submit">Search</button> <input type="hidden" name="sort" value="relevance" /> <input type="hidden" name="range" value="2019-04-30" /></form></div></header><main><div class="container"><nav id="nav-reader-tools" class="navbar navbar-expand d-none d-lg-flex"><ul class="nav-menu navbar-nav ml-auto"><li id="menu-item-101999" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-101999"><a href="https://www.tsln.com/about-us/">About Us</a><span>|</span></li><li id="menu-item-102000" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-102000"><a href="https://www.tsln.com/contribute/">Contribute</a><span>|</span></li><li id="menu-item-102001" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-102001"><a href="https://www.tsln.com/contact-us/">Contact Us</a><span>|</span></li><li id="menu-item-102002" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-102002"><a href="https://swiftiservices.dticloud.com/cmo_cmo/subscriber/web/signin.html?siteId=TSLN">Subscribe</a><span>|</span></li><li id="menu-item-102003" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-102003"><a href="http://www.swiftlocalsolutions.com/advertise-with-tri-state-livestock-news">Advertise</a><span>|</span></li><li id="menu-item-102066" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-102066"><a href="https://www.tsln.com/store-locator/">Pick up a Copy</a><span>|</span></li></ul></nav><div id="primary"><div class="container-fluid" style="margin-bottom: 20px;"><div class="row justify-content-center"><div id="ad-top" class="dfp"> <script>dfp.cmd.push(function() {
						dfp.loadSlot('ad-top', {
								'breakpoints': {
									'xl': true,
									'l': true,
									'm': true,
									's': true,
									'xs': true
								}
						})
				});</script> </div></div></div><div id="layout-single"><div class="d-lg-flex"><article class="flex-fill"><h1>Results: National High School Rodeo Association Finals</h1><p class="article-meta"><a href="https://www.tsln.com/recent-stories/news">News</a> <span class="text-muted">| July 29, 2019</span></p><div id="article-byline"><div class="d-flex"> <strong><address></address></strong><div class="article-social ml-auto"><ul class="nav"><li class="nav-item"> <a class="nav-link" href="https://twitter.com/intent/tweet?text=Results: National High School Rodeo Association Finals&url=https://www.tsln.com/?p=104227" target="_blank"><i class="fab fa-twitter icon-twitter"></i></a></li><li class="nav-item"> <a class="nav-link" href="https://www.facebook.com/dialog/share?app_id=498110130268044&href=https://www.tsln.com/news/results-national-high-school-rodeo-association-finals-81/" target="_blank"><i class="fab fa-facebook-f icon-facebook"></i></a></li><li class="nav-item d-sm-none d-md-block"> <a class="nav-link" href="mailto:?subject=Results: National High School Rodeo Association Finals&body=Top 15 from each event. For more results, see nhsra.com Barrel Racing Average 1. (UT) Macee McAllister, St. George, Utah, 51.937 2. (MT) Shai McDonald, Gardiner, Mont., 52.276 3. (SK) Brooke Lang, Cadillac, Saskatchewan, Can.,...%0D%0A%0D%0Ahttps://www.tsln.com/news/results-national-high-school-rodeo-association-finals-81/"><i class="fas fa-envelope icon-email"></i></a></li><li class="nav-item d-sm-none d-md-block"> <a class="nav-link" href="#" onclick="window.print();return false;"><i class="fas fa-print icon-printer"></i></a></li></ul></div></div></div><div class="p402_premium"><p class="TSLN-TSLN Body copy">Top 15 from each event.</p><p class="TSLN-TSLN Body copy">For more results, see nhsra.com</p><p class="TSLN-TSLN Body copy" /><p class="TSLN-TSLN Body copy">Barrel Racing Average</p><div class="col-sm-12 text-center"><div class="module-ad"><div id="ad-parallax2" class="dfp"> <script>jQuery(window).on('load',function() {
				dfp.cmd.push(function() {
					 dfp.loadSlot('ad-parallax2', {
						 'breakpoints': {
						 'xl': true,
						 'l': true,
						 'm': true,
						 's': true,
						 'xs': true
						 }
					 })
			 });
		 	});</script> </div></div></div><p class="TSLN-TSLN Body copy" /><p class="TSLN-TSLN Body copy">1. (UT) Macee McAllister, St. George, Utah, 51.937</p><p class="TSLN-TSLN Body copy">2. (MT) Shai McDonald, Gardiner, Mont., 52.276</p><div class="col-sm-12 text-center"><div class="module-ad"><div id="ad-big-box4" class="dfp"> <script>dfp.cmd.push(function() {
						dfp.loadSlot('ad-big-box4', {
							'breakpoints': {
							'xl': true,
							'l': true,
							'm': true,
							's': true,
							'xs': true
							}
						})
				});</script> </div></div></div><p class="TSLN-TSLN Body copy">3. (SK) Brooke Lang, Cadillac, Saskatchewan, Can., 52.304</p><p class="TSLN-TSLN Body copy">4. (CO) Kinlie Brennise, Craig, Colo., 52.315</p><p class="TSLN-TSLN Body copy">5. (UT) Amanda Butler, Payson, Utah, 52.323</p><p class="TSLN-TSLN Body copy">6. (ID) Lindsey Peterson, Ogden, Utah, 52.476</p><p class="TSLN-TSLN Body copy">7. (OK) Jaiden Wilmoth, Gentry, Ark., 52.511</p><p class="TSLN-TSLN Body copy">8. (OK) Paige Jones, Wayne, Okla., 52.568</p><p class="TSLN-TSLN Body copy">9. (WY) Ellie Bard, Sheridan, Wyo., 52.637</p><p class="TSLN-TSLN Body copy">10. (CO) Grace Hill, Peyton, Colo., 52.659</p><p class="TSLN-TSLN Body copy">11. (BC) Taya Hamming, Falkland, British Columbia, Can., 52.701</p><p class="TSLN-TSLN Body copy">12. (AZ) Serena Hubbell, Patagonia, Ariz., 52.91</p><p class="TSLN-TSLN Body copy">13. (UT) Kamryn Carlsen, Neola, Utah, 52.992</p><p class="TSLN-TSLN Body copy">14. (AZ) Jacqueline Nichols, Queen Creek, Ariz., 53.609</p><p class="TSLN-TSLN Body copy">15. (AR) Shelbi Rice, Natural Dam, Ark., 53.881</p><p class="TSLN-TSLN Body copy" /><p class="TSLN-TSLN Body copy">Bareback Riding Average</p><p class="TSLN-TSLN Body copy" /><p class="TSLN-TSLN Body copy">1. (CO) Keenan Hayes, Hayden, Colo., 232</p><p class="TSLN-TSLN Body copy">2. (ID) Cooper Cooke, Victor, Idaho, 226</p><p class="TSLN-TSLN Body copy">3. (TX) Cole Franks, Clarendon, Texas, 220</p><p class="TSLN-TSLN Body copy">4. (MT) Brice Patterson, Bozeman, Mont., 219</p><p class="TSLN-TSLN Body copy">5. (AZ) JC Mortensen, Paulden, Ariz., 218</p><p class="TSLN-TSLN Body copy">6. (OR) Mason Stuller, Veneta, Ore., 214</p><p class="TSLN-TSLN Body copy">7. (UT) Bubba Holcomb, New Harmony, Utah, 210</p><p class="TSLN-TSLN Body copy">8. (TX) Kolt Dement, Rusk, Texas, 209</p><p class="TSLN-TSLN Body copy">9. (KS) Ty Pope, Garnett, Kan., 208</p><p class="TSLN-TSLN Body copy">10. (AZ) Matt Tuni, Dennehotso, Ariz., 206</p><p class="TSLN-TSLN Body copy">11. (MT) Sam Petersen, Helena, Mont., 203</p><p class="TSLN-TSLN Body copy">12. (KS) Colt Eck, Redfield, Kan., 199</p><p class="TSLN-TSLN Body copy">13. (WY) Donny Proffit, Diamondville, Wyo., 197</p><p class="TSLN-TSLN Body copy">14. (CA) Jacek Frost, Grenada, Calif., 190</p><p class="TSLN-TSLN Body copy">15. (MT) Sebastian Hotalen, Three Forks, Mont., 180</p><p class="TSLN-TSLN Body copy">Boys Cutting Average</p><p class="TSLN-TSLN Body copy" /><p class="TSLN-TSLN Body copy">1. (TX) Chaser Crouch, Corsicana, Texas, 440</p><p class="TSLN-TSLN Body copy">2. (TX) Carson Ray, Groveton, Texas, 439</p><p class="TSLN-TSLN Body copy">3. (WA) Tice Hiner, Walla Walla, Wash., 433</p><p class="TSLN-TSLN Body copy">4. (WA) Bodeen Sleeman, Yelm, Wash., 429</p><p class="TSLN-TSLN Body copy">5. (ID) Colt Ramsey, Pinedale, Wyo., 428</p><p class="TSLN-TSLN Body copy">6. (IA) Henry Dean, Glenwood, Iowa, 425.5</p><p class="TSLN-TSLN Body copy">7. (TX) Clay Dukes, Weatherford, Texas, 423</p><p class="TSLN-TSLN Body copy">8. (NE) Colten Storer, Arthur, Neb., 421.5</p><p class="TSLN-TSLN Body copy">9. (AB) Kade Christianson, Nanton, Alberta, Can., 421</p><p class="TSLN-TSLN Body copy">9. (TX) Brendan Bennett, Notrees, Texas, 421</p><p class="TSLN-TSLN Body copy">11. (AZ) Cashton Weidenbener, Queen Creek, Ariz., 419.5</p><p class="TSLN-TSLN Body copy">12. (CO) Regan Wheatley, Calhan, Colo., 416</p><p class="TSLN-TSLN Body copy">13. (UT) Dawson Zaharias, Bluffdale, Utah, 415.5</p><p class="TSLN-TSLN Body copy">14. (CO) Kody Ward, Fort Lupton, Colo., 413</p><p class="TSLN-TSLN Body copy">15. (NM) Trey Mitchell, Lamy, N.M., 411</p><p class="TSLN-TSLN Body copy" /><p class="TSLN-TSLN Body copy">Breakaway Roping Average</p><p class="TSLN-TSLN Body copy" /><p class="TSLN-TSLN Body copy">1. (UT) Dallie Bastian, Neola, Utah, 7.11</p><p class="TSLN-TSLN Body copy">2. (TX) Jordi Edens, Gatesville, Texas, 7.91</p><p class="TSLN-TSLN Body copy">3. (LA) Bailey Mudd, Lake Charles, La., 7.93</p><p class="TSLN-TSLN Body copy">4. (KS) Hannah Hughes, Fort Scott, Kan., 8.26</p><p class="TSLN-TSLN Body copy">5. (WI) Ella Sander, Steuben, Wis., 9.45</p><p class="TSLN-TSLN Body copy">6. (CA) Rylee George, Oakdale, Calif., 9.78</p><p class="TSLN-TSLN Body copy">7. (MO) Taylor Mason, Marshall, Mo., 10.57</p><p class="TSLN-TSLN Body copy">8. (OH) Bella Corcoran, Adamsville, Pa., 10.98</p><p class="TSLN-TSLN Body copy">9. (HI) Kilihea Mockchew, Honaunau, Hawaii, 11.59</p><p class="TSLN-TSLN Body copy">10. (NV) Payton Feyder, Lamoille, Nev., 12.61</p><p class="TSLN-TSLN Body copy">11. (FL) Britta Strain, Davie, Fla., 15.19</p><p class="TSLN-TSLN Body copy">12. (WY) Ellie Bard, Sheridan, Wyo., 15.34</p><p class="TSLN-TSLN Body copy">13. (IA) Brie Wells, LeMars, Iowa, 19.18</p><p class="TSLN-TSLN Body copy">14. (LA) Morgan Sparks, Marthaville, La., 4.88</p><p class="TSLN-TSLN Body copy">15. (KS) Caxton Martin, Alma, Kan., 5.42</p><p class="TSLN-TSLN Body copy" /><p class="TSLN-TSLN Body copy" /><p class="TSLN-TSLN Body copy">Bull Riding Average</p><p class="TSLN-TSLN Body copy" /><p class="TSLN-TSLN Body copy">1. (OK) Caden Bunch, Tahlequah, Okla., 148</p><p class="TSLN-TSLN Body copy">2. (AB) Quade Hughson, Foremost, Alberta, Can., 145</p><p class="TSLN-TSLN Body copy">2. (ID) Kade Bruno, Challis, Idaho, 145</p><p class="TSLN-TSLN Body copy">4. (UT) Brek Sanderson, Cedar City, Utah, 125</p><p class="TSLN-TSLN Body copy">5. (SD) Jestyn Woodward, Custer, S.D., 84</p><p class="TSLN-TSLN Body copy">6. (AU) Chris Wilson, Parkville, , 83</p><p class="TSLN-TSLN Body copy">7. (NM) Clay Garley, Los Lunas, N.M., 80</p><p class="TSLN-TSLN Body copy">8. (SC) Kade Stokes, Landrum, S.C., 78</p><p class="TSLN-TSLN Body copy">8. (OK) Lukasey Morris, Atoka, Okla., 78</p><p class="TSLN-TSLN Body copy">10. (NM) Owen Pruett, Tularosa, N.M., 77</p><p class="TSLN-TSLN Body copy">10. (AZ) Jake Dunham, Tucson, Ariz., 77</p><p class="TSLN-TSLN Body copy">10. (IA) Bubba Greig, Estherville, Iowa, 77</p><p class="TSLN-TSLN Body copy">13. (WY) Wyatt Phelps, Pinedale, Wyo., 76</p><p class="TSLN-TSLN Body copy">14. (NM) Joseph Chavez, Moriarty, N.M., 74</p><p class="TSLN-TSLN Body copy">14. (OR) Cole Hill, Klamath Falls, Ore., 74</p><p class="TSLN-TSLN Body copy">14. (CA) TJ Gray, Klamath Falls, Ore., 74</p><p class="TSLN-TSLN Body copy" /><p class="TSLN-TSLN Body copy">Tie-Down Roping Average</p><p class="TSLN-TSLN Body copy" /><p class="TSLN-TSLN Body copy">1. (TX) Shad Mayfield, Clovis, N.M., 25.37</p><p class="TSLN-TSLN Body copy">2. (UT) Braydin Evans, Erda, Utah, 27.35</p><p class="TSLN-TSLN Body copy">3. (OR) Trent Sorey, Pendleton, Ore., 27.76</p><p class="TSLN-TSLN Body copy">4. (AZ) Dean Holyan, Coyote Canyon, N.M., 27.97</p><p class="TSLN-TSLN Body copy">5. (FL) Sam Morgan, Southwest Ranches, Fla., 28.69</p><p class="TSLN-TSLN Body copy">6. (ID) Brayden Roe, Wendell, Idaho, 28.87</p><p class="TSLN-TSLN Body copy">7. (CO) Jace Logan, Yampa, Colo., 29.7</p><p class="TSLN-TSLN Body copy">8. (AB) Jason Smith, Wimborne, Alberta, Can., 30.53</p><p class="TSLN-TSLN Body copy">9. (TX) Kase Bacque, Port Barre, La., 30.74</p><p class="TSLN-TSLN Body copy">10. (UT) Kash Cattoor, Hurricane, Utah, 31.15</p><p class="TSLN-TSLN Body copy">11. (IN) Clint Southworth, Bagdad, Ky., 31.28</p><p class="TSLN-TSLN Body copy">12. (GA) Jacob Daniell, Monroe, Ga., 31.67</p><p class="TSLN-TSLN Body copy">13. (SD) Blase Steffen, Gregory, S.D., 33.43</p><p class="TSLN-TSLN Body copy">14. (OK) Anthony Craig, Okmulgee, Okla., 19.19</p><p class="TSLN-TSLN Body copy">15. (MB) Stran Dunham, Souris, Manitoba, Can., 19.73</p><p class="TSLN-TSLN Body copy" /><p class="TSLN-TSLN Body copy">Girls Cutting Average</p><p class="TSLN-TSLN Body copy" /><p class="TSLN-TSLN Body copy">1. (TX) Ryann Packard, Weatherford, Texas, 444</p><p class="TSLN-TSLN Body copy">2. (MS) Karrigan Cagley, Kentwood, La., 442</p><p class="TSLN-TSLN Body copy">3. (ID) Kiersten Brockett, Star, Idaho, 438</p><p class="TSLN-TSLN Body copy">4. (TX) Ellie Schreck, Murphy, Texas, 435</p><p class="TSLN-TSLN Body copy">5. (KS) Faith Miller, Allen, Kan., 433.5</p><p class="TSLN-TSLN Body copy">6. (TX) Hannah King, Baird, Texas, 433</p><p class="TSLN-TSLN Body copy">7. (CA) Gracie Lopez, Solvang, Calif., 431</p><p class="TSLN-TSLN Body copy">8. (UT) Taylor Porter, Morgan, Utah, 428</p><p class="TSLN-TSLN Body copy">9. (UT) Sydney Davis, Lapoint, Utah, 427</p><p class="TSLN-TSLN Body copy">10. (OK) Kaitlyn Ramer, Sulphur, Okla., 426</p><p class="TSLN-TSLN Body copy">11. (KS) Kensley Barnett, Oakley, Kan., 425</p><p class="TSLN-TSLN Body copy">11. (HI) Laura Coflin, Pukalani, Hawaii, 425</p><p class="TSLN-TSLN Body copy">13. (CO) Trea Allen, Kiowa, Colo., 423.5</p><p class="TSLN-TSLN Body copy">14. (ND) Kazanne Gjermundson, Marshall, N.D., 422</p><p class="TSLN-TSLN Body copy">15. (AZ) Avery Shriver, Morristown, Ariz., 420</p><p class="TSLN-TSLN Body copy" /><p class="TSLN-TSLN Body copy">Goat Tying Average</p><p class="TSLN-TSLN Body copy" /><p class="TSLN-TSLN Body copy">1. (OK) Taitum Thomas, Coalgate, Okla., 23.43</p><p class="TSLN-TSLN Body copy">2. (UT) Maddie Roche, West Valley City, Utah, 24.15</p><p class="TSLN-TSLN Body copy">3. (WY) Brooke Worman, Clearmont, Wyo., 24.17</p><p class="TSLN-TSLN Body copy">4. (KS) Kyleigh Winn, Westmoreland, Kan., 24.22</p><p class="TSLN-TSLN Body copy">5. (AB) Kyla Kelly, Red Deer County, Alberta, Can., 24.31</p><p class="TSLN-TSLN Body copy">6. (AZ) Dakota Keenan, San Tan Valley, Ariz., 24.81</p><p class="TSLN-TSLN Body copy">7. (ID) Laynee Gregersen, Malta, Idaho, 24.96</p><p class="TSLN-TSLN Body copy">8. (ND) Molly Rotenberger, Ludlow, S.D., 25.5</p><p class="TSLN-TSLN Body copy">9. (NE) Wacey Day, Fleming, Colo., 25.54</p><p class="TSLN-TSLN Body copy">10. (WA) Elizabeth Bolich, Mead, Wash., 25.68</p><p class="TSLN-TSLN Body copy">11. (UT) Keni Labrum, Vernal, Utah, 25.72</p><p class="TSLN-TSLN Body copy">12. (CA) Maggie Usher, Santa Ynez, Calif., 25.98</p><p class="TSLN-TSLN Body copy">13. (AB) Brooke Swaffield, Dawson Creek, British Columbia, Can., 26.92</p><p class="TSLN-TSLN Body copy">14. (OR) Kennedy Buckner, Redmond, Ore., 27.27</p><p class="TSLN-TSLN Body copy">15. (SK) Cassidy Weber, Carlyle, Saskatchewan, Can., 27.94</p><p class="TSLN-TSLN Body copy" /><p class="TSLN-TSLN Body copy">Pole Bending Average</p><p class="TSLN-TSLN Body copy" /><p class="TSLN-TSLN Body copy">1. (UT) Kenna Coronado, Kanarraville, Utah, 60.626</p><p class="TSLN-TSLN Body copy">2. (TX) Reagan Davis, Alto, Texas, 60.897</p><p class="TSLN-TSLN Body copy">3. (AZ) Jacqueline Nichols, Queen Creek, Ariz., 61.033</p><p class="TSLN-TSLN Body copy">4. (IN) Maci Zimmerman, New Ross, Ind., 61.324</p><p class="TSLN-TSLN Body copy">5. (NE) Madison Mills, Eddyville, Neb., 61.488</p><p class="TSLN-TSLN Body copy">6. (OR) Cate Hepper, Fort Klamath, Ore., 61.632</p><p class="TSLN-TSLN Body copy">7. (CO) Jacobi Larson, Fowler, Colo., 61.706</p><p class="TSLN-TSLN Body copy">8. (WI) Morgan Rud, Mondovi, Wis., 61.747</p><p class="TSLN-TSLN Body copy">9. (TX) Aspen Grant, Buna, Texas, 61.962</p><p class="TSLN-TSLN Body copy">10. (CA) Payton Schoeppach, Lincoln, Calif., 61.983</p><p class="TSLN-TSLN Body copy">11. (SK) Cassidy Weber, Carlyle, Saskatchewan, Can., 62.591</p><p class="TSLN-TSLN Body copy">12. (OK) Chaley Hext, Canadian, Texas, 62.745</p><p class="TSLN-TSLN Body copy">13. (AR) Courtney Keaton, Anderson, Mo., 62.765</p><p class="TSLN-TSLN Body copy">14. (OK) Cashen Turner, Edmond, Okla., 63.025</p><p class="TSLN-TSLN Body copy">15. (WY) Maddie Wolff, Gillette, Wyo., 66.011</p><p class="TSLN-TSLN Body copy" /><p class="TSLN-TSLN Body copy">Saddle Bronc Average</p><p class="TSLN-TSLN Body copy" /><p class="TSLN-TSLN Body copy">1. (UT) Clayson Hutchings, Springville, Utah, 212</p><p class="TSLN-TSLN Body copy">2. (SD) Cash Wilson, Wall, S.D., 208</p><p class="TSLN-TSLN Body copy">3. (TX) Gus Gaillard, Morse, Texas, 206</p><p class="TSLN-TSLN Body copy">4. (SD) Talon Elshere, Hereford, S.D., 187</p><p class="TSLN-TSLN Body copy">5. (TX) Bonner Voss, Stamford, Texas, 169</p><p class="TSLN-TSLN Body copy">6. (ND) Kain Stroh, Dickinson, N.D., 157</p><p class="TSLN-TSLN Body copy">7. (ID) Kade Bruno, Challis, Idaho, 151</p><p class="TSLN-TSLN Body copy">8. (OR) Mason Stuller, Veneta, Ore., 144</p><p class="TSLN-TSLN Body copy">9. (NE) Sage Miller, Springview, Neb., 143</p><p class="TSLN-TSLN Body copy">10. (LA) Coy Hebert, DeRidder, La., 141</p><p class="TSLN-TSLN Body copy">11. (KS) Weston Patterson, Waverly, Kan., 140</p><p class="TSLN-TSLN Body copy">12. (UT) Scott Lauaki, Springville, Utah, 137</p><p class="TSLN-TSLN Body copy">13. (TX) Jake Vance, Joshua, Texas, 132</p><p class="TSLN-TSLN Body copy">14. (WI) Tanner Bassett, Boscobel, Wis., 101</p><p class="TSLN-TSLN Body copy">15. (OK) Briar Teague, Rattan, Okla., 100</p><p class="TSLN-TSLN Body copy" /><p class="TSLN-TSLN Body copy">Steer Wrestling Average</p><p class="TSLN-TSLN Body copy" /><p class="TSLN-TSLN Body copy">1. (CO) Jace Logan, Yampa, Colo., 15.18</p><p class="TSLN-TSLN Body copy">2. (SD) Wynn Schaack, Wall, S.D., 16.08</p><p class="TSLN-TSLN Body copy">3. (MN) Garrett Stevens, Hammond, Wis., 18.5</p><p class="TSLN-TSLN Body copy">4. (LA) Brad Hesnor, Ville Platte, La., 18.55</p><p class="TSLN-TSLN Body copy">5. (WA) Samuel Mundell, Kingston, Wash., 19.69</p><p class="TSLN-TSLN Body copy">6. (FL) Sam Morgan, Southwest Ranches, Fla., 20.34</p><p class="TSLN-TSLN Body copy">7. (ID) Whitt Smith, Lewiston, Utah, 20.53</p><p class="TSLN-TSLN Body copy">8. (WY) Kaden Berger, Gillette, Wyo., 20.71</p><p class="TSLN-TSLN Body copy">9. (HI) Westin Joseph, Hilo, Hawaii, 20.82</p><p class="TSLN-TSLN Body copy">10. (GA) Riley Kittle, Woodland, Ala., 21.67</p><p class="TSLN-TSLN Body copy">11. (NE) Cauy Pokorny, Stapleton, Neb., 22.65</p><p class="TSLN-TSLN Body copy">12. (TX) Jake Kahla, Jasper, Texas, 25.78</p><p class="TSLN-TSLN Body copy">13. (WY) Winsten McGraw, Gill, Colo., 37.18</p><p class="TSLN-TSLN Body copy">14. (GA) Jacob Daniell, Monroe, Ga., 8.91</p><p class="TSLN-TSLN Body copy">15. (KS) Tanner Meier, Garden City, Kan., 14.76</p><p class="TSLN-TSLN Body copy" /><p class="TSLN-TSLN Body copy">Team Roping Average</p><p class="TSLN-TSLN Body copy" /><p class="TSLN-TSLN Body copy">1. (MS) Kason Davis, Lumberton, Miss., Bryce Graves, Poplarville, Miss., 19.35</p><p class="TSLN-TSLN Body copy">2. (WY) Arye Espenscheid, Big Piney, Wyo., Kolby Bradley, Big Piney, Wyo., 20.24</p><p class="TSLN-TSLN Body copy">3. (KS) Trey Adams, Junction City, Kan., Camden Hoelting, Olpe, Kan., 22.43</p><p class="TSLN-TSLN Body copy">4. (NC) Cole Futrell, Union Grove, N.C., Blake Walker II, Forest City, N.C., 24.32</p><p class="TSLN-TSLN Body copy">5. (UT) Daxton Hill, Spanish Fork, Utah, Kash Cattoor, Hurricane, Utah, 28.58</p><p class="TSLN-TSLN Body copy">6. (MS) Cole Curry, Liberty, Miss., Preston Day, Kentwood, La., 28.98</p><p class="TSLN-TSLN Body copy">7. (TX) Chet Weitz, London, Texas, Mason Pitts, Haughton, La., 30.53</p><p class="TSLN-TSLN Body copy">8. (WY) Blake Afdahl, Torrington, Wyo., Clay Reiner, Buffalo, Wyo., 34.67</p><p class="TSLN-TSLN Body copy">9. (IA) Payton Weehler, Maloy, Iowa, Jaxson Davis, Bloomfield, Iowa, 35.69</p><p class="TSLN-TSLN Body copy">10. (AZ) Clay Cherry, Stanfield, Ariz., Bodie Hine, Ignacio, Colo., 38.2</p><p class="TSLN-TSLN Body copy">11. (UT) Blake Bowler, Enterprise, Utah, TJ Bowler, Enterprise, Utah, 41.23</p><p class="TSLN-TSLN Body copy">12. (NM) Tarren Washburn, Corona, N.M., John Hisel, Clovis, N.M., 44.19</p><p class="TSLN-TSLN Body copy">13. (GA) Joey Denney, Carrollton, Ga., Riley Kittle, Woodland, Ala., 15.61</p><p class="TSLN-TSLN Body copy">14. (FL) Trey Mills III, LaBelle, Fla., Parker Carbajal, New Smyrna Beach, Fla., 20.2</p><p class="TSLN-TSLN Body copy">15. (NC) Eli Colvard, Crumpler, N.C., Frog Bass, Statesville, N.C., 21.11</p><p class="TSLN-TSLN Body copy" /><p class="TSLN-TSLN Body copy">Reined Cow Horse Average</p><p class="TSLN-TSLN Body copy" /><p class="TSLN-TSLN Body copy">1. (NV) Ali Norcutt, Fallon, Nev., 866</p><p class="TSLN-TSLN Body copy">2. (TX) Trail Townsend, Earth, Texas, 865.5</p><p class="TSLN-TSLN Body copy">3. (OK) Shayla Boyce, Purcell, Okla., 864</p><p class="TSLN-TSLN Body copy">4. (UT) Sydney Davis, Lapoint, Utah, 862</p><p class="TSLN-TSLN Body copy">5. (ID) Breanna Jenkins, Rexburg, Idaho, 859.5</p><p class="TSLN-TSLN Body copy">6. (NM) Trey Mitchell, Lamy, N.M., 859</p><p class="TSLN-TSLN Body copy">6. (CO) Regan Wheatley, Calhan, Colo., 859</p><p class="TSLN-TSLN Body copy">8. (AZ) Garrett Hershberger, Litchfield Park, Ariz., 858.5</p><p class="TSLN-TSLN Body copy">8. (MN) Katie Udell, Independence, Minn., 858.5</p><p class="TSLN-TSLN Body copy">10. (KS) Gage Gardiner, Ashland, Kan., 858</p><p class="TSLN-TSLN Body copy">11. (WY) Maddie Fantaskey, Worland, Wyo., 857.5</p><p class="TSLN-TSLN Body copy">11. (CA) Pierce Wold, Wilton, Calif., 857.5</p><p class="TSLN-TSLN Body copy">13. (WY) Peyton Kottwitz, Lusk, Wyo., 857</p><p class="TSLN-TSLN Body copy">14. (OK) LaRae Luis, Wynnewood, Okla., 856.5</p><p class="TSLN-TSLN Body copy">15. (NE) Tatum Olson, Bloomfield, Neb., 854.5</p><p class="TSLN-TSLN Body copy" /><p class="TSLN-TSLN Body copy">Team Standings</p><p class="TSLN-TSLN Body copy">1. TEXAS, 12,260.00</p><p class="TSLN-TSLN Body copy">2. UTAH, 10,375.00</p><p class="TSLN-TSLN Body copy">3. IDAHO, 6,793.50</p><p class="TSLN-TSLN Body copy">4. KANSAS, 6,037.50</p><p class="TSLN-TSLN Body copy">5. OKLAHOMA, 5,647.00</p><p class="TSLN-TSLN Body copy">6. ARIZONA, 5,605.00</p><p class="TSLN-TSLN Body copy">7. WYOMING, 5,232.50</p><p class="TSLN-TSLN Body copy">8. COLORADO, 4,835.00</p><p class="TSLN-TSLN Body copy">9. SOUTH DAKOTA, 3,457.50</p><p class="TSLN-TSLN Body copy">10. OREGON, 3,330.00</p><p class="TSLN-TSLN Body copy">11. CALIFORNIA, 3,310.00</p><p class="TSLN-TSLN Body copy">12. NEBRASKA, 2,990.00</p><p class="TSLN-TSLN Body copy">13. ALBERTA, 2,675.00</p><p class="TSLN-TSLN Body copy">14. NEW MEXICO, 2,585.00</p><p class="TSLN-TSLN Body copy">14. MONTANA, 2,585.00</p><p class="TSLN-TSLN Body copy">16. LOUISIANA, 2,580.00</p><p class="TSLN-TSLN Body copy">17. IOWA, 2,450.00</p><p class="TSLN-TSLN Body copy">18. MISSISSIPPI, 2,435.00</p><p class="TSLN-TSLN Body copy">19. WASHINGTON, 2,285.00</p><p class="TSLN-TSLN Body copy">20. FLORIDA, 1,870.00</p><p class="TSLN-TSLN Body copy">21. NORTH DAKOTA, 1,686.00</p><p class="TSLN-TSLN Body copy" /><p class="TSLN-TSLN Body copy">Boys Team Standings</p><p class="TSLN-TSLN Body copy">1. TEXAS, 8,020.00</p><p class="TSLN-TSLN Body copy">2. UTAH, 4,650.00</p><p class="TSLN-TSLN Body copy">3. IDAHO, 4,547.50</p><p class="TSLN-TSLN Body copy">4. ARIZONA, 3,655.00</p><p class="TSLN-TSLN Body copy">5. COLORADO, 3,125.00</p><p class="TSLN-TSLN Body copy">6. KANSAS, 3,017.50</p><p class="TSLN-TSLN Body copy">7. SOUTH DAKOTA, 2,587.50</p><p class="TSLN-TSLN Body copy">8. NEW MEXICO, 2,395.00</p><p class="TSLN-TSLN Body copy">9. WYOMING, 2,342.50</p><p class="TSLN-TSLN Body copy">10. OREGON, 2,310.00</p><p class="TSLN-TSLN Body copy">11. OKLAHOMA, 2,035.00</p><p class="TSLN-TSLN Body copy">12. WASHINGTON, 1,975.00</p><p class="TSLN-TSLN Body copy">13. NEBRASKA, 1,920.00</p><p class="TSLN-TSLN Body copy">14. ALBERTA, 1,605.00</p><p class="TSLN-TSLN Body copy">15. MISSISSIPPI, 1,545.00</p><p class="TSLN-TSLN Body copy">16. CALIFORNIA, 1,490.00</p><p class="TSLN-TSLN Body copy">17. MONTANA, 1,480.00</p><p class="TSLN-TSLN Body copy">18. FLORIDA, 1,370.00</p><p class="TSLN-TSLN Body copy">19. LOUISIANA, 1,315.00</p><p class="TSLN-TSLN Body copy">20. GEORGIA, 1,300.00</p><p class="TSLN-TSLN Body copy">21. IOWA, 1,275.00</p><p class="TSLN-TSLN Body copy">22. NORTH CAROLINA, 810.00</p><p class="TSLN-TSLN Body copy">23. MINNESOTA, 765.00</p><p class="TSLN-TSLN Body copy">24. NORTH DAKOTA, 505.00</p><p class="TSLN-TSLN Body copy" /><p class="TSLN-TSLN Body copy">Girls Team Standings</p><p class="TSLN-TSLN Body copy">1. UTAH, 5,725.00</p><p class="TSLN-TSLN Body copy">2. TEXAS, 4,240.00</p><p class="TSLN-TSLN Body copy">3. OKLAHOMA, 3,612.00</p><p class="TSLN-TSLN Body copy">4. KANSAS, 3,020.00</p><p class="TSLN-TSLN Body copy">5. WYOMING, 2,890.00</p><p class="TSLN-TSLN Body copy">6. IDAHO, 2,246.00</p><p class="TSLN-TSLN Body copy">7. ARIZONA, 1,950.00</p><p class="TSLN-TSLN Body copy">8. CALIFORNIA, 1,820.00</p><p class="TSLN-TSLN Body copy">9. COLORADO, 1,710.00</p><p class="TSLN-TSLN Body copy">10. LOUISIANA, 1,265.00</p><p class="TSLN-TSLN Body copy">11. NORTH DAKOTA, 1,181.00</p><p class="TSLN-TSLN Body copy">12. IOWA, 1,175.00</p><p class="TSLN-TSLN Body copy">13. MONTANA, 1,105.00</p><p class="TSLN-TSLN Body copy">14. NEVADA, 1,091.00</p><p class="TSLN-TSLN Body copy">15. NEBRASKA, 1,070.00</p><p class="TSLN-TSLN Body copy">15. ALBERTA, 1,070.00</p><p class="TSLN-TSLN Body copy">17. OREGON, 1,020.00</p><p class="TSLN-TSLN Body copy">18. MISSISSIPPI, 890.00</p><p class="TSLN-TSLN Body copy">19. SASKATCHEWAN, 885.00</p><p class="TSLN-TSLN Body copy">20. SOUTH DAKOTA, 870.00</p><p class="TSLN-TSLN Body copy" /><p class="TSLN-TSLN Body copy" /><p class="TSLN-TSLN Body copy">AQHA Girls Horse of the Year</p><p class="TSLN-TSLN Body copy">1. (NE) Mr Poco Jack Sprat, Madison Mills, NE, 500.00</p><p class="TSLN-TSLN Body copy">2. (WI) Pocos Pepper Mac, Ella Sander, WI, 455.00</p><p class="TSLN-TSLN Body copy">3. (WY) Chin N Smooth “Tex”, Shay Hough, WY, 300.00</p><p class="TSLN-TSLN Body copy">4. (SD) Seban Magic Scotty, Mikenzy Miller, SD, 170.00</p><p class="TSLN-TSLN Body copy">5. (ID) Miss Docs Huds King, Kaylee Cornia, WY, 100.00</p><p class="TSLN-TSLN Body copy">6. (WV) AA Hialeos Ben Peppy, Makayla Osborne, WV, 40.00</p><p class="TSLN-TSLN Body copy">7. (IL) RNS Runnerella, Mary Thompson, IL, 20.00</p><p class="TSLN-TSLN Body copy" /><p class="TSLN-TSLN Body copy" /><p class="TSLN-TSLN Body copy">AQHA Boys Horse of the Year</p><p class="TSLN-TSLN Body copy">1. (WA) Atticus Cat, Tice Hiner, WA, 620.00</p><p class="TSLN-TSLN Body copy">2. (NM) SCR Crackin One Time, Trey Mitchell, NM, 470.00</p><p class="TSLN-TSLN Body copy">3. (LA) Little Thorn Olena “Bobcat”, Brad Hesnor, LA, 400.00</p><p class="TSLN-TSLN Body copy">4. (GA) Sugs Lightning Cat “Earl”, Jacob Daniell, GA, 310.00</p><p class="TSLN-TSLN Body copy">5. (MB) Kola Signature, Stran Dunham, MB, 230.00</p><p class="TSLN-TSLN Body copy">6. (TX) Hammer Lippy, Trevor Hale, TX, 210.00</p><p class="TSLN-TSLN Body copy">7. (ND) The Rodeo Dash “Rodeo”, Clayton Backhaus, ND, 80.00</p><p class="TSLN-TSLN Body copy">8. (OK) Royal Hottie, Landon Little, OK, 55.00</p><p class="TSLN-TSLN Body copy" /><p class="TSLN-TSLN Body copy" /><p class="TSLN-TSLN Body copy">ALL AROUND COWGIRL</p><p class="TSLN-TSLN Body copy">1. (UT) Kenna Coronado, Kanarraville, Utah, 870.00</p><p class="TSLN-TSLN Body copy">2. (AZ) Jacqueline Nichols, Queen Creek, Ariz., 820.00</p><p class="TSLN-TSLN Body copy">3. (OK) Shayla Boyce, Purcell, Okla., 810.00</p><p class="TSLN-TSLN Body copy">4. (UT) Sydney Davis, Lapoint, Utah, 785.00</p><p class="TSLN-TSLN Body copy">5. (MS) Karrigan Cagley, Kentwood, La., 750.00</p><p class="TSLN-TSLN Body copy">6. (CA) Payton Schoeppach, Lincoln, Calif., 690.00</p><p class="TSLN-TSLN Body copy">7. (IA) Brie Wells, LeMars, Iowa, 555.00</p><p class="TSLN-TSLN Body copy">8. (WY) Ellie Bard, Sheridan, Wyo., 540.00</p><p class="TSLN-TSLN Body copy">9. (KS) Caxton Martin, Alma, Kan., 480.00</p><p class="TSLN-TSLN Body copy">10. (KS) Tylor Todd, Rexford, Kan., 425.00</p><p class="TSLN-TSLN Body copy" /><p class="TSLN-TSLN Body copy" /><p class="TSLN-TSLN Body copy">ALL AROUND ROOKIE COWGIRL</p><p class="TSLN-TSLN Body copy">1. (WY) Haiden Thompson, Yoder, Wyo., 280.00</p><p class="TSLN-TSLN Body copy">2. (BC) Taya Hamming, Falkland, British Columbia, Can., 340.00</p><p class="TSLN-TSLN Body copy">3. (NV) Tayler Felton, Fallon, Nev., 200.00</p><p class="TSLN-TSLN Body copy">4. (FL) Lacey Nail, Okeechobee, Fla., 90.00</p><p class="TSLN-TSLN Body copy">5. (MS) Logan Wilson, Louin, Miss., 70.00</p><p class="TSLN-TSLN Body copy">6. (WV) Makayla Osborne, Fayetteville, W.V., 40.00</p><p class="TSLN-TSLN Body copy">7. (MO) Danielle Lichte, Pleasant Hill, Mo., 10.00</p><p class="TSLN-TSLN Body copy">8. (UT) Dallie Bastian, Neola, Utah, 740.00</p><p class="TSLN-TSLN Body copy">9. (TX) Ryann Packard, Weatherford, Texas, 655.00</p><p class="TSLN-TSLN Body copy">10. (ID) Kiersten Brockett, Star, Idaho, 546.00</p><p class="TSLN-TSLN Body copy" /><p class="TSLN-TSLN Body copy" /><p class="TSLN-TSLN Body copy">ALL AROUND COWBOY</p><p class="TSLN-TSLN Body copy">1. (CO) Jace Logan, Yampa, Colo., 1,120.00</p><p class="TSLN-TSLN Body copy">2. (FL) Sam Morgan, Southwest Ranches, Fla., 1,040.00</p><p class="TSLN-TSLN Body copy">3-4. (ID) Kade Bruno, Challis, Idaho, 1,025.00</p><p class="TSLN-TSLN Body copy">3-4. (OR) Mason Stuller, Veneta, Ore., 1,025.00</p><p class="TSLN-TSLN Body copy">5. (ID) Cooper Cooke, Victor, Idaho, 890.00</p><p class="TSLN-TSLN Body copy">6-7. (UT) Kash Cattoor, Hurricane, Utah, 885.00</p><p class="TSLN-TSLN Body copy">6-7. (CO) Regan Wheatley, Calhan, Colo., 885.00</p><p class="TSLN-TSLN Body copy">8. (MS) Kason Davis, Lumberton, Miss., 870.00</p><p class="TSLN-TSLN Body copy">9. (GA) Jacob Daniell, Monroe, Ga., 780.00</p><p class="TSLN-TSLN Body copy">10. (NM) Trey Mitchell, Lamy, N.M., 740.00</p><p class="TSLN-TSLN Body copy" /><p class="TSLN-TSLN Body copy" /><p class="TSLN-TSLN Body copy">ALL AROUND ROOKIE COWBOY</p><p class="TSLN-TSLN Body copy">1. (OR) Mason Stuller, Veneta, Ore., 1,025.00</p><p class="TSLN-TSLN Body copy">2. (IA) Payton Weehler, Maloy, Iowa, 310.00</p><p class="TSLN-TSLN Body copy">3. (CO) Kody Ward, Fort Lupton, Colo., 315.00</p><p class="TSLN-TSLN Body copy">4. (TN) Bryson Tays, Crossville, Tenn., 30.00</p><p class="TSLN-TSLN Body copy">5. (MD) Tanner Naylor, Hancock, Md., 20.00</p><p class="TSLN-TSLN Body copy">6. (TX) Gus Gaillard, Morse, Texas, 600.00</p><p class="TSLN-TSLN Body copy">7. (TX) Clay Dukes, Weatherford, Texas, 575.00</p><p class="TSLN-TSLN Body copy">8. (KS) Trey Adams, Junction City, Kan., 560.00</p><p class="TSLN-TSLN Body copy">9. (WA) Bodeen Sleeman, Yelm, Wash., 550.00</p><p class="TSLN-TSLN Body copy">10. (OK) Caden Bunch, Tahlequah, Okla., 515.00  F</p><p class="TSLN-TSLN Body copy">–NHSRA</p></div> <script type="text/javascript">try { _402_Show(); } catch(e) {}</script> <hr /><div class="fb-comments" data-href="https://www.tsln.com/?p=104227" data-width="100%" data-numposts="3"></div><hr /><div class="row"><div class="masonry-item col-md-12"><div class="module module-dual-column card shadow-sm"><div class="card-header"><i class="far fa-newspaper icon-section"></i> News</div><div class="card-body"><section><article><div class="row no-gutters"><div class="col-lg-5 card-img featured text-center"> <a href="https://www.tsln.com/news/nrcs-offers-more-than-200-million-in-emergency-funding-to-restore-flood-prone-lands/"><img src="https://cdn.tsln.com/wp-content/uploads/sites/13/2019/07/Screen-Shot-2019-07-25-at-8.03.31-AM.png" alt="NRCS Offers more than $200 Million in Emergency Funding to Restore Flood-Prone Lands" /></a></div><div class="col card-text"><h4><a href="https://www.tsln.com/news/nrcs-offers-more-than-200-million-in-emergency-funding-to-restore-flood-prone-lands/">NRCS Offers more than $200 Million in Emergency Funding to Restore Flood-Prone Lands</a></h4><p class="card-meta"><span class="text-muted">July 25, 2019</span></p><p class="card-excerpt d-lg-none d-xl-block"></p></div></div></article><hr /><div class="row"><div class="col col-hero"><article><div class="row no-gutters"><div class="col-3 card-img"> <a href="https://www.tsln.com/news/karla-trautman-named-sdsu-extension-director/"><img src="https://cdn.tsln.com/wp-content/uploads/sites/13/2019/07/trautman-tsln-072719-199x300.jpg" alt="Karla Trautman Named SDSU Extension Director" /></a></div><div class="col card-text"><h6><a href="https://www.tsln.com/news/karla-trautman-named-sdsu-extension-director/">Karla Trautman Named SDSU Extension Director</a></h6><p class="card-meta"><span class="text-muted">July 22, 2019</span></p></div></div></article><hr /><article><div class="row no-gutters"><div class="col card-text"><h6><a href="https://www.tsln.com/news/asi-submits-comments-on-gray-wolf-delisting/">ASI Submits Comments on Gray Wolf Delisting</a></h6><p class="card-meta"><span class="text-muted">July 19, 2019</span></p></div></div></article><hr class="d-md-none d-lg-none d-xl-none" /></div><div class="col col-hero"><article><div class="row no-gutters"><div class="col card-text"><h6><a href="https://www.tsln.com/news/the-cavalry-group-defending-the-basic-right-to-own-animals/">The Cavalry Group:  Defending the basic right to own animals</a></h6><p class="card-meta"><span class="text-muted">July 5, 2019</span></p></div></div></article><hr /><article><div class="row no-gutters"><div class="col card-text"><h6><a href="https://www.tsln.com/news/results-national-high-school-rodeo-association-finals-11/">Results: National High School Rodeo Association Finals</a></h6><p class="card-meta"><span class="text-muted">July 29, 2019</span></p></div></div></article></div></div><hr /></section> <a href="https://www.tsln.com/recent-stories/news/" class="card-link card-more float-right">See more <i class="fas fa-angle-right"></i></a></div></div></div></div></article><aside><div class="masonry-container row"><div class="masonry-item col-sm-12 text-center"><div class="module-ad ad-big-box1"><div id="ad-big-box1" class="dfp"> <script>dfp.cmd.push(function() {
               dfp.loadSlot('ad-big-box1', {
                   'breakpoints': {
         'xl': true,
         'l': true,
         'm': true,
         's': true,
         'xs': true
                   }
               })
           });</script> </div></div></div><div class="masonry-item col-sm-12 col-md-6 col-lg-12"><div class="module module-weather card shadow-sm"><div class="card-header"><i class="wi wi-day-sunny"></i> 5-Day Forecast</div><div class="card-body"><div class="row"><div class="col text-center"> <i class="wi wi-day-cloudy"></i><p><strong>Mon</strong><br /> <span class="card-meta">H: 77&deg;<br /> L: 53&deg;</span><br /></p></div><div class="col text-center"> <i class="wi wi-day-cloudy"></i><p><strong>Tue</strong><br /> <span class="card-meta">H: 84&deg;<br /> L: 58&deg;</span><br /></p></div><div class="col text-center"> <i class="wi wi-rain"></i><p><strong>Wed</strong><br /> <span class="card-meta">H: 88&deg;<br /> L: 61&deg;</span><br /></p></div><div class="col text-center"> <i class="wi wi-rain"></i><p><strong>Thu</strong><br /> <span class="card-meta">H: 76&deg;<br /> L: 66&deg;</span><br /></p></div><div class="col text-center"> <i class="wi wi-rain"></i><p><strong>Fri</strong><br /> <span class="card-meta">H: 83&deg;<br /> L: 62&deg;</span><br /></p></div></div><hr /><a href="https://www.tsln.com/forecast/" class="card-link card-more float-right">See more <i class="fas fa-angle-right"></i></a></div></div></div><div class="masonry-item col-sm-12 text-center"><div class="module-ad ad-big-box2"><div id="ad-big-box2" class="dfp"> <script>dfp.cmd.push(function() {
               dfp.loadSlot('ad-big-box2', {
                   'breakpoints': {
         'xl': true,
         'l': true,
         'm': true,
         's': true,
         'xs': true
                   }
               })
           });</script> </div></div></div><div class="masonry-item col-sm-12 col-md-6 col-lg-12"><div class="module module-gallery module-c2 card shadow-sm"><div class="card-header"></div><div class="card-body"><h5 class="card-title">Top Jobs</h5><div id="carousel-101898" class="carousel slide" data-ride="carousel" data-interval="5000"><div class="carousel-inner"><div class="carousel-item active" style="overflow:hidden;padding-left: 20px;"><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.tsln.com/ad/Employment/Agriculture-Animals/mechanicmechanic/1-0000456800-01" target="_blank">Lost Creek Dairy ,Lost Creek Dairy </a></h5><h6>Mechanic,Mechanic</h6><p style="font-size:.875rem;"><em></em><br><span>Farm/Ag Dairy Mechanic Wanted Lost Creek Dairy is taking applications for a full-time mechanic. Responsibilities&hellip;</span></p></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.tsln.com/ad/Employment/Agriculture-Animals/truck-drivertruck-driver/1-0000456819-01" target="_blank">Lost Creek Dairy,Lost Creek Dairy</a></h5><h6>Truck Driver,Truck Driver</h6><p style="font-size:.875rem;"><em></em><br><span>Full-time and Part-time Class A Truck Drivers Needed Driver will haul agricultural commodities from vendor&hellip;</span></p></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.tsln.com/ad/Employment/Agriculture-Animals/feed-truck-driver/1-0000452851-01" target="_blank">Diamond Feeders</a></h5><h6>Feed Truck Driver</h6><p style="font-size:.875rem;"><em></em><br><span>DIAMOND FEEDERS Now looking for a full-time, feed truck driver. Competitive wages, 401K, and health&hellip;</span></p></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.tsln.com/ad/Employment/Agriculture-Animals/-help-wanted/1-0000458360-01" target="_blank">-,-</a></h5><h6>-,Help Wanted</h6><p style="font-size:.875rem;"><em></em><br><span>HELP WANTED married couple to work on a cow calf operation in North East Wyoming.&hellip;</span></p></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.tsln.com/ad/Employment/Agriculture-Animals/ranch-hand-wantedranch-hand-wanted/1-0000459105-01" target="_blank">private,private</a></h5><h6>Ranch Hand Wanted,Ranch Hand Wanted</h6><p style="font-size:.875rem;"><em></em><br><span>RANCH HAND WANTED SEEKING FULL-TIME RANCH HAND FOR COW/CALF OPERATION With some farming experience required&hellip;</span></p></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.tsln.com/ad/Employment/Agriculture-Animals/inside-sales-account-manager-inside-sal/1-0000453129-01" target="_blank">Tri-State Livestock News/Farmer Rancher Exchange,Tri-State Livestock news/Fence Post/Farmer Rancher Exchange</a></h5><h6>Inside Sales Account Manager, Inside Sales Account Manager</h6><p style="font-size:.875rem;"><em></em><br><span>The Classified Department at Tri-State Livestock News / The Fence Post has an immediate opening&hellip;</span></p></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.tsln.com/ad/Employment/Agriculture-Animals/trout-hatchery-employee/1-0000453800-01" target="_blank">n/a</a></h5><h6>Trout Hatchery Employee</h6><p style="font-size:.875rem;"><em></em><br><span>TROUT HATCHERY EMPLOYEE Looking for Individual who would like topursue a career in aquaculture. Applicant&hellip;</span></p></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.tsln.com/ad/Employment/Agriculture-Animals/feed-crew-help-/1-0000456990-01" target="_blank">.,-</a></h5><h6>Feed Crew Help,-</h6><p style="font-size:.875rem;"><em></em><br><span>HELP WANTED Privately owned feed yard in Northeast Colorado is looking for help on feed&hellip;</span></p></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"> <a href="http://classifieds.tsln.com/ad/Employment/Business-Ops/business-opportunity-patent-opportunity/1-0000453211-01" target="_blank" style="display: block;max-width: 75px;float:left;margin-right: 10px;"><img class="slide-image" src="https://snmg.swift-ads.com/onlineimages/79/0000369279-01-0.jpg" alt="Business Opportunity ,Patent Opportunity" style="margin: 0 auto 4px auto;width: auto;max-height: 100px;"></a><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.tsln.com/ad/Employment/Business-Ops/business-opportunity-patent-opportunity/1-0000453211-01" target="_blank">Service Line Inc. ,Steven Meyer Service Line Inc</a></h5><h6>Business Opportunity ,Patent Opportunity</h6><p style="font-size:.875rem;"><em></em><br><span>BUSINESS OPPORTUNITY PATENT FOR SALE Innovative Equipment for Programmable Livestock Feeding. Product Fully Engineered, Developed&hellip;</span></p></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.tsln.com/ad/Employment/Agriculture-Animals/feed-truck-operator/1-0000455435-01" target="_blank">Thompson Farms</a></h5><h6>Feed Truck Operator</h6><p style="font-size:.875rem;"><em></em><br><span>HELP WANTED Feed truck operator and general feedlot maintenance wanted. Housing available. Pay commensurate with&hellip;</span></p></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.tsln.com/ad/Employment/Agriculture-Animals/seeking-team-oriented-individual-with-eq/1-0000456927-01" target="_blank">Angus Cows/Grow Yard,-</a></h5><h6>Seeking Team Oriented Individual with Equipment and Livestock Experience,-</h6><p style="font-size:.875rem;"><em></em><br><span>HELP WANTED Family Sized Grow Yard/Cow Herd Seeking Skilled Individual to join our team. Responsible&hellip;</span></p></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.tsln.com/ad/Employment/Agriculture-Animals/pen-riders/1-0000451683-01" target="_blank">Five Rivers Cattle Feeding </a></h5><h6>Pen Riders</h6><p style="font-size:.875rem;"><em></em><br><span>NOW HIRING!! Have you ever dreamed of working with cattle on a large-scale cattle feeding&hellip;</span></p></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.tsln.com/ad/Employment/Agriculture-Animals/summer-ranch-irrigation-job/1-0000459477-01" target="_blank">Escalante Ranch</a></h5><h6>Summer Ranch Irrigation Job</h6><p style="font-size:.875rem;"><em></em><br><span>Experienced Flood Irrigator Needed Delta Colorado Ranch. Full time. Housing available. Good salary and benefits.&hellip;</span></p></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.tsln.com/ad/Employment/Agriculture-Animals/position-on-a-purebred-ranch-in-se-wyomi/1-0000457977-01" target="_blank">Haas Angus,--</a></h5><h6>Position on a Purebred Ranch in SE Wyoming,--</h6><p style="font-size:.875rem;"><em></em><br><span>HELP WANTED Purebred Ranch in SE Wyoming has a position open for employment. No Farming.&hellip;</span></p></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.tsln.com/ad/Employment/Agriculture-Animals/livestock-farm-manager/1-0000458308-01" target="_blank"></a></h5><h6>Livestock Farm Manager</h6><p style="font-size:.875rem;"><em></em><br><span>Livestock Farm Manager Full Time Position Oversees the day to day operation of a back&hellip;</span></p></div></div></div><div class="carousel-nav d-flex justify-content-center"><a class="carousel-control-prev position-absolute" style="width:60px;height:40px;top:100px;left:-30px;" href="#carousel-101898" role="button" data-slide="prev"> <i class="fas fa-chevron-left"></i> <span class="sr-only">Previous</span> </a><ol class="carousel-indicators position-relative"><li data-target="#carousel-101898" data-slide-to="1" class="active"></li><li data-target="#carousel-101898" data-slide-to="2" class=""></li><li data-target="#carousel-101898" data-slide-to="3" class=""></li><li data-target="#carousel-101898" data-slide-to="4" class=""></li><li data-target="#carousel-101898" data-slide-to="5" class=""></li><li data-target="#carousel-101898" data-slide-to="6" class=""></li><li data-target="#carousel-101898" data-slide-to="7" class=""></li><li data-target="#carousel-101898" data-slide-to="8" class=""></li><li data-target="#carousel-101898" data-slide-to="9" class=""></li><li data-target="#carousel-101898" data-slide-to="10" class=""></li><li data-target="#carousel-101898" data-slide-to="11" class=""></li><li data-target="#carousel-101898" data-slide-to="12" class=""></li><li data-target="#carousel-101898" data-slide-to="13" class=""></li><li data-target="#carousel-101898" data-slide-to="14" class=""></li><li data-target="#carousel-101898" data-slide-to="15" class=""></li></ol><a class="carousel-control-next position-absolute" style="width:60px;height:40px;top:100px;right:-30px;" href="#carousel-101898" role="button" data-slide="next"> <i class="fas fa-chevron-right"></i> <span class="sr-only">Next</span> </a></div></div><hr /><a href="http://classifieds.tsln.com/category/Employment" class="card-link card-more float-right" target="_blank">View more listings <i class="fas fa-angle-right"></i></a></div></div></div></div></aside></div></div></div></div></main><nav id="nav-mobile-footer" class="fixed-bottom d-lg-none d-xl-none"><ul class="nav nav-fill"><li class="nav-item"> <a class="nav-link " href="https://www.tsln.com"><i class="fas fa-home icon"></i><br/>Home</a></li><li class="nav-item"> <a class="nav-link " href="https://www.tsln.com/trending-stories/news/"><i class="fas fa-chart-line icon"></i><br/>Trending</a></li><li class="nav-item"> <a class="nav-link" id="mobile-back-to-top" href="#" class="hamburger-button collapsed" type="button" data-toggle="collapse" data-target="#nav-mobile-menu" aria-controls="nav-mobile-menu" aria-expanded="false" aria-label="Toggle navigation"><i class="fas fa-bars icon"></i><br/>Sections</a></li></ul></nav><footer><div class="container"><nav id="nav-footer"><div class="row"><div class="col-md-5 offset-md-1 order-md-4"><ul class="nav nav-social justify-content-center justify-content-md-end"><li class="nav-item"><a class="nav-link" href="https://twitter.com/TSLivestockNews" target="_blank"> <span class="fa-stack fa-2x"> <i class="fas fa-circle fa-stack-2x bg-twitter icon-circle"></i> <i class="fab fa-twitter fa-stack-1x icon-social"></i> </span></a></li><li class="nav-item"><a class="nav-link" href="ttps://www.facebook.com/tslivestocknews/" target="_blank"> <span class="fa-stack fa-2x"> <i class="fas fa-circle fa-stack-2x bg-facebook-f icon-circle"></i> <i class="fab fa-facebook-f fa-stack-1x icon-social"></i> </span></a></li><li class="nav-item"><a class="nav-link" href="https://www.instagram.com/tslivestocknews/" target="_blank"> <span class="fa-stack fa-2x"> <i class="fas fa-circle fa-stack-2x bg-instagram icon-circle"></i> <i class="fab fa-instagram fa-stack-1x icon-social"></i> </span></a></li></ul></div><div class="col-md-2 nav-list order-md-1"><h6>Marketplace</h6><ul class="nav flex-md-column"><li id="menu-item-102050" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-102050"><a href="http://classifieds.tsln.com/category/Employment">Jobs</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-102051" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-102051"><a href="http://classifieds.tsln.com/">Classifieds</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-102052" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-102052"><a href="http://classifieds.tsln.com/category/Livestock+and+Animals">Livestock &#038; Animals</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-102053" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-102053"><a href="http://classifieds.tsln.com/category/Hay+and+Feed">Hay &#038; Feed</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-102054" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-102054"><a href="http://classifieds.tsln.com/category/Farm+and+Ranch+Equipment">Farm &#038; Ranch Equipment</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-102055" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-102055"><a href="http://classifieds.tsln.com/category/Merchandise">Merchandise</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-102056" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-102056"><a href="http://classifieds.tsln.com/category/Transportation">Autos</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-102057" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-102057"><a href="http://classifieds.tsln.com/category/Real+Estate+For+Sale">Real Estate</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-102058" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-102058"><a href="http://classifieds.tsln.com/category/Recreation">Recreation</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-102059" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-102059"><a href="http://classifieds.tsln.com/category/Business+and+Service+Directory">Service Directory</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-102060" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-102060"><a href="http://classifieds.tsln.com/category/Pets">Pets</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-102061" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-102061"><a href="http://classifieds.tsln.com/category/Announcements">Announcements</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-102062" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-102062"><a href="http://classifieds.tsln.com/category/Financial">Financial</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-102063" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-102063"><a href="http://classifieds.tsln.com/category/Legals">Legals</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-102064" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-102064"><a href="http://classifieds.tsln.com/category/Garage+Sales">Garage Sales</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li></ul></div><div class="col-md-2 nav-list order-md-2"><h6>Reader Tools</h6><ul class="nav flex-md-column"><li id="menu-item-102038" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-102038"><a href="https://www.tsln.com/contact-us/">Contact Us</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-102039" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-102039"><a href="https://www.tsln.com/contribute/">Contribute</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-102041" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-102041"><a href="https://swiftiservices.dticloud.com/cgi-bin/cmo_cmo.sh/custservice/web/login.html?siteid=TSLN">Subscriber Services</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-102042" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-102042"><a href="https://syncaccess-swc-tsln.syncronex.com/swc/tsln/account/logon?returnUrl=http://subscriber.pagesuite-professional.co.uk/custompages/swiftcommunications/signedin.aspx?pbid=TSLN">E-Paper</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-102043" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-102043"><a href="http://www.swiftlocalsolutions.com/advertise-with-tri-state-livestock-news">Advertise</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-102044" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-102044"><a href="http://tristatelivestocknews.secondstreetapp.com/Newsletter-Sign-up-Page/">Newsletters</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-102045" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-102045"><a href="https://secure.adpay.com/AdEntry.aspx?p=9182">Place a Classified Ad</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-102046" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-102046"><a href="https://www.tsln.com/search-results/">Archives</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-102047" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-102047"><a href="https://www.tsln.com/feed/">RSS</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-102048" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-102048"><a href="https://swiftiservices.dticloud.com/cmo_cmo/subscriber/web/signin.html?siteId=TSLN">Subscribe-TSLN</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-102040" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-102040"><a href="https://www.tsln.com/cookie-list/">Cookie List</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li></ul></div><div class="col-md-2 nav-list order-md-3"><h6>News Neighbors</h6><ul class="nav flex-md-column"><li id="menu-item-102049" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-102049"><a href="https://www.thefencepost.com/">Rural News of Colorado &#038; Nebraska</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li></ul></div></div></nav><nav id="nav-footer-sub"><ul class="nav justify-content-center"><li id="menu-item-102034" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-102034"><a href="https://www.tsln.com/about-us/">About Us</a><span>|</span></li><li id="menu-item-102035" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-102035"><a href="https://cdn.tsln.com/wp-content/uploads/2016/09/AdvertisingTermsandConditions09-12-11.pdf">Terms &#038; Conditions</a><span>|</span></li><li id="menu-item-102036" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-102036"><a href="https://www.tsln.com/terms-of-use/">Terms of Use</a><span>|</span></li><li id="menu-item-102037" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-102037"><a href="https://www.tsln.com/privacy-policy/">Privacy Policy</a><span>|</span></li></ul><p class="text-center text-muted">©2005 - 2019 Swift Communications, Inc.</p></nav></div></footer> <script>( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );</script> <script async src="https://www.googletagmanager.com/gtag/js?id=AW-1066460699"></script> <script>window.dataLayer = window.dataLayer || [];
					  function gtag(){dataLayer.push(arguments);}
					  gtag('js', new Date());
					  gtag('config', 'AW-1066460699');</script> <script>_qevents.push({qacct:"p-ddTeiQ57W1ULk"});</script> <noscript> <img src="https://pixel.quantserve.com/pixel/p-a1bk1DtLRmBjE.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/> </noscript> <script>jQuery(function($) {
						if ( $( '.wp-audio-shortcode' ).length ) {
							$( 'audio' ).mediaelementplayer({
								success: function(mediaElement, domObject, instance) {
		        			mediaElement.addEventListener('loadeddata', function() {
										ga( 'send', 'event', 'audio', 'play' );
										ga( 'newTracker.send', 'event', 'audio', 'play' );
				        	}, false);
									mediaElement.addEventListener('loadstart', function() {
										$( '.mejs-audio a.audio-download' ).click(function() {
											ga( 'send', 'event', 'audio', 'download' );
											ga( 'newTracker.send', 'event', 'audio', 'download' );
										});
									}, false);
		  					}
							});
						}
					});</script><script>/* <![CDATA[ */ var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};var tribe_system_info = {"sysinfo_optin_nonce":"576c95c2c7","clipboard_btn_text":"Copy to clipboard","clipboard_copied_text":"System info copied","clipboard_fail_text":"Press \"Cmd + C\" to copy"}; /* ]]> */</script><script type='text/javascript'>/* <![CDATA[ */ var pollsL10n = {"ajax_url":"https:\/\/www.tsln.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"}; /* ]]> */</script> <script data-minify="1" type='text/javascript' src='https://cdn.tsln.com/wp-content/cache/min/13/wp-content/plugins/wp-polls/polls-js-e31f829aac12ee3003178a6976e486d0.js'></script> <script data-minify="1" type='text/javascript' src='https://cdn.tsln.com/wp-content/cache/min/13/wp-content/themes/swift-news-theme/assets/js/vendors/popper-87cf0da7c1ecce9b32a1ac839c583880.js'></script> <script type='text/javascript' src='https://cdn.tsln.com/wp-content/cache/busting/13/wp-content/themes/swift-news-theme/assets/js/vendors/recliner.min-0.2.3.js'></script> <script data-minify="1" type='text/javascript' src='https://cdn.tsln.com/wp-content/cache/min/13/wp-content/themes/swift-news-theme/assets/js/vendors/bootstrap-fae9895715ccb5ad8f743dc1ec995d94.js'></script> <script data-minify="1" type='text/javascript' src='https://cdn.tsln.com/wp-content/cache/min/13/wp-content/themes/swift-news-theme/assets/js/vendors/bootstrap-datepicker-5039cdd411c03e235c36f63a55bafee2.js'></script> <script data-minify="1" type='text/javascript' src='https://cdn.tsln.com/wp-content/cache/min/13/wp-content/themes/swift-news-theme/assets/js/vendors/masonry-40b546908667d89e2329962be79cb420.js'></script> <script data-minify="1" type='text/javascript' src='https://cdn.tsln.com/wp-content/cache/min/13/wp-content/themes/swift-news-theme/assets/js/vendors/images-loaded-ded7717ffd78a35ce8c7b49dc34d8b84.js'></script> <script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/fancybox/3.5.6/jquery.fancybox.min.js?ver=3.5.6'></script> <script data-minify="1" type='text/javascript' src='https://cdn.tsln.com/wp-content/cache/min/13/wp-content/themes/swift-news-theme/assets/js/vendors/lightslider-d0cab75f3c72de792f70947dd43df6fb.js'></script> <script data-minify="1" type='text/javascript' src='https://cdn.tsln.com/wp-content/cache/min/13/wp-content/themes/swift-news-theme/assets/js/vendors/lightgallery-37bfe41e00e7ae41625ca7c0ca0099a4.js'></script> <script type='text/javascript' src='https://cdn.tsln.com/wp-content/cache/busting/13/wp-content/themes/swift-news-theme/assets/js/vendors/if-4-bootstrap-breakpoint.min-1.0.0.js'></script> <script type='text/javascript'>/* <![CDATA[ */ var more_briefs = {"ajaxurl":"https:\/\/www.tsln.com\/wp-admin\/admin-ajax.php","briefs_nonce":"28a3c89846"}; /* ]]> */</script> <script data-minify="1" type='text/javascript' src='https://cdn.tsln.com/wp-content/cache/min/13/wp-content/themes/swift-news-theme/assets/js/main-fcc398b727733b273c67df81b657f21b.js'></script> <script type='text/javascript' src='https://cookie-cdn.cookiepro.com/consent/483d8421-7196-4a3e-aa35-b7b171469915.js?ver=1.0'></script> <script type='text/javascript'>function OptanonWrapper() { }</script> <script data-minify="1" type='text/javascript' src='https://cdn.tsln.com/wp-content/cache/min/13/wp-content/themes/swift-news-theme/assets/js/vendors/syncwall-login-api-2db74319e878507519eec9a345ab01dc.js'></script> <script type='text/javascript'>var swiftSiteID = 'TSLN'</script> <script type='text/javascript' src='https://cdn.tsln.com/wp-includes/js/wp-embed.min.js'></script> <script>var loggedIn = ( readCookie("syncwall-authToken") == null ) ? 'no' : 'yes';
var swiftLanguage = ( accessCookie("swift_language") == null ) ? 'english' : accessCookie("swift_language");
ga('set', {'dimension1': 'News','dimension2': 'None','dimension3': 'News/None','dimension5': loggedIn,'dimension6': '(none)','dimension7': '','dimension8': '2019-07-29','dimension9': 'wp-104227','dimension10': '','dimension12': '2019-07-29 16:26:00','dimension13': '7','dimension14': 'article','dimension15': '1596','dimension16': '','dimension18': swiftLanguage});
ga('newTracker.set', {'dimension1': 'News','dimension2': 'None','dimension3': 'News/None','dimension5': loggedIn,'dimension6': '(none)','dimension7': '','dimension8': '2019-07-29','dimension9': 'wp-104227','dimension10': '','dimension12': '2019-07-29 16:26:00','dimension13': '7','dimension14': 'article','dimension15': '1596','dimension16': '','dimension18': swiftLanguage});

	      var gaUserId = readCookie("sync-subscriberId");
	      if ( gaUserId ) {
	        ga('set', 'userId', gaUserId );
	        ga('newTracker.set', 'userId', gaUserId );
	      }
			ga('provide', 'adblockTracker', function(tracker, opts) {
			  var ad = document.createElement('ins');
			  ad.className = 'AdSense';
			  ad.style.display = 'block';
			  ad.style.position = 'absolute';
			  ad.style.top = '-1px';
			  ad.style.height = '1px';
			  document.body.appendChild(ad);
				var adBlockEnabled = !ad.clientHeight ? 'yes' : 'no';
			  tracker.set('dimension' + opts.dimensionIndex, adBlockEnabled);
			  document.body.removeChild(ad);
			});
			ga('require', 'adblockTracker', {dimensionIndex: 11});
      var currLocation = String(document.location);
      // strip out email addresses from location url
      var emailRegex = /([a-zA-Z0-9_\.-]+)@([\da-zA-Z\.-]+)\.([a-zA-Z\.]{2,6})/i;
      var cleanPageLocation = currLocation.replace(emailRegex, "");

      ga('set', 'location', cleanPageLocation);
			ga('set', 'anonymizeIp', true);
			ga('newTracker.set', 'location', cleanPageLocation);
			ga('newTracker.set', 'anonymizeIp', true);
				ga('send', 'pageview');
				ga('newTracker.send', 'pageview');</script><script>var chartbeatUser = ( readCookie("syncwall-authToken") == null ) ? 'anon' : 'paid';
	        var _sf_async_config = _sf_async_config || {};
	        _sf_async_config.uid = 57640; _sf_async_config.domain = 'swiftcom.com'; _sf_async_config.useCanonical = true;
	      	_sf_async_config.sections = 'TSLN.com,news';
	      	_sf_async_config.authors = '(none)';
	        _sf_async_config.title = 'Results: National High School Rodeo Association Finals | TSLN.com';
	  			var _cbq = window._cbq = (window._cbq || []);
	      	_cbq.push(['_acct', chartbeatUser]);
	        (function(){
	          function loadChartbeat() {
	            window._sf_endpt=(new Date()).getTime();
	            var e = document.createElement('script');
	            e.setAttribute('language', 'javascript');
	            e.setAttribute('type', 'text/javascript');
	            e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
	            document.body.appendChild(e);
	          }
	          var oldonload = window.onload;
	          window.onload = (typeof window.onload != 'function') ?
	              loadChartbeat : function() {
	                  oldonload();
	                  loadChartbeat();
	              };
	        })();</script><script>(function(w, d){
	var b = d.getElementsByTagName("body")[0];
	var s = d.createElement("script"); s.async = true;
	s.src = !("IntersectionObserver" in w) ? "https://cdn.tsln.com/wp-content/plugins/wp-rocket/inc/front/js/lazyload-8.15.2.min.js" : "https://cdn.tsln.com/wp-content/plugins/wp-rocket/inc/front/js/lazyload-10.17.min.js";
	w.lazyLoadOptions = {
		elements_selector: "iframe",
		data_src: "lazy-src",
		data_srcset: "lazy-srcset",
		data_sizes: "lazy-sizes",
		skip_invisible: false,
		class_loading: "lazyloading",
		class_loaded: "lazyloaded",
		threshold: 300,
		callback_load: function(element) {
			if ( element.tagName === "IFRAME" && element.dataset.rocketLazyload == "fitvidscompatible" ) {
				if (element.classList.contains("lazyloaded") ) {
					if (typeof window.jQuery != "undefined") {
						if (jQuery.fn.fitVids) {
							jQuery(element).parent().fitVids();
						}
					}
				}
			}
		}
	}; // Your options here. See "recipes" for more information about async.
	b.appendChild(s);
}(window, document));

// Listen to the Initialized event
window.addEventListener('LazyLoad::Initialized', function (e) {
    // Get the instance and puts it in the lazyLoadInstance variable
	var lazyLoadInstance = e.detail.instance;

	var observer = new MutationObserver(function(mutations) {
		mutations.forEach(function(mutation) {
			lazyLoadInstance.update();
		} );
	} );

	var b      = document.getElementsByTagName("body")[0];
	var config = { childList: true, subtree: true };

	observer.observe(b, config);
}, false);</script> </body></html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1564466123 -->